Error type 4 on firmware update

When i do the new firmware 1.5 update to my denom DJ prime 4, on openning crashes and return error type 4 (both USB or mac update), and i have to update to the older version 1.4 to unblock by pressing power and eject buttons. Can you help me how to resolve, please?

Hello @Nelson, Welcome to the forum.

For Your issue, please download the updater once again. The previous one can have an error (can happen during downlad).

Check if this can fix it.

I tried but unsucessful…

I notice it says Engine Prime failed to start.

Engine Prime is the library software for your computer, not for the Prime 4.

1 Like

But it is the return error on prime 4, after 1.5 firmware update…and on booting with 1.4. always returns this error.

You haven’t got Engine Prime running on your computer whilst you’re doing this, have you?

Nop. I also have tried with a PC instead of Mac. Shoul i have engine on?

Common sense should tell you that NO you should not be running Engine Prime.

I was just curious as to why the Prime 4 screen should be saying something about Engine Prime.

Thanks for your attention

Good eyes :smiley: In version 1.5 ENGINE OS should appear on the screen not ENGINE PRIME. That indicates wrong update file is used.

But i did with the update software avaiable on denom site. The firmware…thks

Can You show us from where did You got the file - direct link, pleaase?

Sure. From here:

OK, so this looks like a valid download. Did You tried to download the updater again?

Yes. I did it, in my Mac, on a PC, i also tried the update in the 2 methods by USB and by pen. And always returns this error.

That looks then like a possible hardware problem. Please try to contact with Denon Dj Global support. Maybe they can help more…?

Thank you very much.

1 Like

just turned mine on after the update 1.5 and it’s telling me the left player display firmware wasn’t installed,

it’s now done it twice. going to have to put the older firmware back on because not risking this coming up at gigs.