EP not loading track in collection (track exist and is playable)

  1. Product: Engine Prime
  2. Software Version: 1.5.0.
  3. Steps to Reproduce:
  • 1-File downloaded (from Soundeo.com, legal) on Laptop SSD in Windows Explorer
  • 2-Cut and paste file to Collection External SSD (Drive dedicated for songs)
  • 3- Open Engine Prime and select (sub)crate
  • 4- Drag and drop file into EP
  1. Expected Result: EP imports file
  2. Actual Result: EP shows error and seems unable to locate or load the file
  3. Reproducibility: Yes
  4. Additional Notes: The problem is it doesn’t happen with all files, and not always directly, sometimes files can be added to the collection, played etc and then out of the blue this happens. From that point on, that file will not be loaded into EP anymore whatever I try, different locations, crates or renaming the file as the added screenshot shows. The video shows the steps. Putting the file on an USB and sticking it into the Denon P4 it plays just fine

  1. Link to Video Repro: https://we.tl/t-cd2GRgJaXx

If you do that, does the album art appear normal ?

Yes it does show the album art as expected. (it shows in EP too btw)

File show as red in EP because the file has either been moved or renamed since it was added. The file location in the database is no longer correct, hence red text.

Solution: Don’t rename or relocate files once you’ve added them to EP.

Take a look at the added video, it shows the file being imported fresh and still showing unavailable. The renaming I tried was used to force a workaround but it did not work (so I renamed the item and tried importing again)

If you upload it to a video sharing site, I’ll watch it.

See number 8 in the original post :wink:

https://we.tl/t-cd2GRgJaXx for your convenience

Yes, I see the link. That’s not a video sharing site. It’s a download.

Ah…well don’t know sharing sites…you mean youtube?? not the kind of thing for youtube imho? Or you got any suggestions?

YouTube is one, yes. Generally if you want to show video clips to others, that’s the type of site to use.

People don’t like having to download unknown files without good reason.

I had a look at it anyway. Can’t see much detail as the video is so blurry, but why are you not using Engine Prime normally, and importing files as directed in the manual?

Why involve Windows Explorer and all the copying, pasting and dragging? Check the file name and location in EP. There must be a reason why the link is broken (file shows red).

I have done it from within EP too, in effect it makes no difference. Dran 'n drop vs I moved the file from location A to Location B to make sure it was a fresh file, and I always move downloads to the collection SSD anyways before importing into EP

So what’s the database file name and location compared to the actual name and location?

Database is on the external SSD and matches actual (E:\collection…\song.mp3) I can drag 'n drop the file from EP into…MP3Tag for instance. The funny thing is that, this happens to a file at random, this file I was able to play a week ago…in EP itself…and noting changed. So I am working as described by the manual, not using my laptop but external SSD as storage (only for download of new tracks) and then importing as prescribed.

Have you changed any of the tags using anything other than engine prime ?

No I haven’t…fresh import…track failed to load…tried reimporting track info etc, then removed it from collection in EP, tried reimporting from SSD, failed. Deleted the track, redownload it, tried reimporting, still a fail…

I’d burn it out to CDRW and re-rip it. Sounds like a poor/corrupted source