Entry point not found

Help!!! Trying to download engine DJ 2.3.2 it downloads and installs no problem but when I try to open it I get this message

It says "the procedure entry point could not be located in the dynamic link library. I have no clue what this means! Any help much appreciated :+1:

Are you using Windows 8.1?

I also have this error with the latest Engine DJ on my laptop using Windows 8.1. Denon have replied saying Windows 8.1 isn’t supported any more.

You can revert using the previous version for now.

1 Like

Hi I’m using windows 10. Thank you for your reply mate.

Is the installed Windows 10 32-bit or 64? What is the processor in your PC: i3, i5, i7 or AMD Ryzen 5, 7…?

1 Like

Hey. I have no idea if I’m honest :grin: it says and a8 on the lappy. Not sure what bit windows is, where would I find that info please? I’ve just tried downloading an older version but still got same error. Thanks for your help

It’s a 64bit mate. Just checked it now

In Windows 10 you have to go to “about your PC” you will have the characteristics of the PC (Processor, amount of ram, precise version of the Builder of Windows 10 and if it is 64 bits or 32)!

https://www.windowscentral.com/how-check-your-computer-full-specifications-windows-10

Ok super already we know that it does not come from an incompatible 32/64 bits, the 32 bits is abandoned. What is the processor in your PC

Entry point not found is an error that indicates that there is a missing or corrupt file in a particular process, which prevents the program from launching. Have you tried reinstalling Engine Dj or running a software repair?

1 Like

Hi mate. Yeah I’ve uninstalled and reinstalled about 5 times! Processor is amr 8. Really frustrating. Luckily I have a SC live 2 so no laptop needed really. Would be good to use Denon software though and not serato. Thanks for your help.

Reinstalling/repairing doesn’t fix the problem for me. I have tried 3 times.

Atleast I now know this isn’t a Windows 8.1 problem.

1 Like

Windows 8.1 has not been supported for several years, it has been abandoned by all developers.

For my part, I have a Windows 10 Bootcamp partition in a 10-year-old Macbook Pro and I haven’t experienced this kind of problem and the same with my old Surface Pro 7 with Windows 11 OS!

The Denon Engine Dj software is a music preparation software and not a mixing and preparation software like Serato Dj Pro is.

You say your PC has an ARM 8 processor and not an Amd Ryzen: 5 / 7 / 9, or intel: i5 / i7 / i9?

ARM processors are dedicated to the tablet and not to PCs, or to certain mini PCs and if this is the case… it will never work!

Sorry pal. It’s amd 8, do you have download you could send me? Perhaps yours doesn’t have the corrupted file inc.

Here : Engine Dj Desktop 2.3.2

Before trying to install Engine Dj Desktop 2.3.2, did you already have another version on your PC?

If so, what was the version?

If you had already installed Engine Dj, maybe the software database is damaged? Have you tried moving the Engine Library folder that is in your Music folder on your PC and putting it on the desktop, then uninstalling Engine Dj Desktop in your programs and after that, reinstalling the software, to see if the problem still exists?

And if with all that nothing works, you will have to check in your programs if you have one of the Visual C++ versions as indicated by AIRVince below.

1 Like

Hey Martin,

It might be that the proper Microsoft support libraries didn’t install properly. You can try installing them from here: Latest supported Visual C++ Redistributable downloads | Microsoft Learn - select the X64 version under the “Visual Studio 2015, 2017, 2019, and 2022” menu.

If that doesn’t solve it, I’d recommend contacting support to see if they can shake things out: Support : Denon DJ

1 Like

I know but the error surely can’t be because windows 8.1, this post now confirms it.

Except that you’re playing with stability and software / OS compatibility, so if it bugs… you don’t have to look for the why and how and complain to Denon! :wink:

Windows 8 is a disaster in terms of stability, it was quickly abandoned, as was Vista! The top Windows OS were XP, 7 and Windows 10 is much better now, more than expected that 11 is at the level or even more than Windows 7.

No mate this is my first time using engine DJ. I do have rekordbox and serato djpro on my lappy though

Thank u. I’ll get this tomorrow. Many thanks for your help

Same for me ! I’m used Serato Dj Pro 3, DJay Pro 2 ! No problem !

EDIT : I forgot… thanks for the clarification!