EngineDj no longer adding playlists since updating to V2.2

Hi all, as the title says. Since I updated to the latest version, I can no longer create playlist. If I manually create a playlist & give it a name, the “folder” with that name is created, but dragging tracks into that playlist dopant add any tracks. I used to be able to simply drag & drop a folder onto my collection icon & it would create a playlist with the same name as the folder, with all the tracks inside it. This does absolutely nothing now - no folder created or anything. I tried rolling back to the previous version, but the old version now has the same problems. I can create playlists on my backup Mac using the same drive without issues. However this is an old 2010 core II duo that’s as slow as hell and it’s not my primary machine. Any help here will be greatly appreciated.

I tried this earlier, but not having the same problem on windows.

I used a folder called ‘test’ with a single song and it worked fine.

Probably not what you wanted to hear. Sorry.

Thanks for checking for me. I eventually found a solution. I uninstalled & deleted everything related to Engine. Then re-installed V2.2. Now it’s working like it should again. Not sure what happened for this to occur, but at least it’s sorted out now. Thanks again.

3 Likes

So unfortunately, V2.2 started doing the exact same thing again, where I can’t add playlists. I decided to go back to V2.1 - Everything is working fine now. So sadly there is def a problem with V2.2

I found the solution I opened a post and then I marked it as a resolution! you should at least try a little to read the various posts in the forum because maybe others have solved! if you prefer to go back to previous versions go ahead!

So whilst we are telling each other what to do… You should at least try not be so condescending. I didn’t do a search of the forum because I had already started this post. You have the time to post here telling me to read, yet don’t have the time to tell me the solution or the inclination to even add a link to your post? Also note that I (nor anyone else on this forum) don’t need your permission to go back to previous versions. Take your attitude somewhere else because it’s not welcome or appreciated here!

1 Like

look do as you want! I at least look if there is a solution in the forum! like those who do not even deign to look at the user manuals of the products, and open random posts !!

Where’s your solution? I’ve searched & I don’t see it. So if you’re not here to help, then don’t bother posting on this thread - Simple!!

1 Like

Back to Engine DJ Desktop 2.1 ! :pensive:

I think his solution is to completely wipe everything. Ha ha.

1 Like

Thanks for the link. I actually saw that post, but honestly didn’t see that as a solution either :rofl:.

I thought after a major release that Denon staff would be monitoring the forum to help with any issues people had with the new software. It seems not and users are just left to figure it all out themselves.

1 Like

I simply deleted the post! you have to learn not to offend people!

there is nothing to laugh about you know! lose a couple of hours and it solves the problem! without losing loops, analysis or hot cues, and using 2.2 without problems, but you are experts and go back to 2.1 !!

In the 14 years I’ve been using my DJ software I’ve never had to wipe anything, it’s still on the original database.

1 Like

yes, but if you find you have problems with 2.2, and you see that formatting the external drives and re-exporting the playlists will work everything back! I mean now I can add the music again and everything works every time! and this without deleting anything from engine dj but only the external disks, that is without losing loops and hotcues! for me that is the solution without waiting for a denon that still hasn’t answered anyone !! Is this not a solution for you? then why laugh!

Point in principle is that you shouldn’t have to do anything. Updates to software and hardware should be seamless. It’s 2022 and Denon are part of a large global player in the music industry.

1 Like

We are laughing because your “solution” is not a solution. It’s a “work-around” and it’s an extreme work-around, just to make use of a buggy V2.2. For those of us who have their entire collection (mine is almost 600Gb) on an external with 3 identical drives as back-ups, reformatting is not an option at all. The drives were (and still are) working perfectly with V2.1. The problem is with V2.2 and Denon need to be aware of this. Everybody having to reformat their drives to use it, is not a solution.

4 Likes

The solution is to move or delete Engine Library Backup! I noticed that every time I do a new backup with Engine Desktop, I can’t add any more files or even export them. Without the Backup folder it works again, at least for drag and drop exports, I haven’t tried with Sync Manager. Tell me, if it works for you also with this solution? Thank’s

Thanks for the info, I’ll give this a try. If I uninstall V2.2 then reinstall it again, it seems to work for that day, then the next time I try, it doesn’t work again. So it’ll take a couple of days to test & see if deleting (or perhaps even renaming?) the backup works. Im holding thumbs that this works. Thanks again.

1 Like