Engine says exFAT MBR hard drive is not compatible?

Hi everyone. Just got my Prime 4 and having a couple of issues getting going. Thanks for any help you can offer. I’m trying to use a WD USB 3.0 2TB empty and working hard drive and as soon as I plug it into my laptop to start to use with Engine, Engine tells me it’s incompatible and needs to be FAT32 or exFAT…but it already is (I checked). Can anyone suggest what might sort this out please? Thanks

Perhaps there is an extra partition preceeding the exFAT? Or some sort of CDROM volume.

Could you post an image from your disk management?

Thanks Reese. Photo below, sorry for the tiny text. It’s the My Passport drive I’m trying to fix.

@ParmoViolet, welcome to the forum btw!

That should all be good.

Absolutely not GPT? Could you right click on disk1; if you see “convert to GPT”, it would indeed be MBR.

Thanks, good to be here! Right clicking shows me option to Convert to Dynamic Disk in black text or Convert to GPT disk greyed out

Sorry I had dry eyes… Your WD Passport seems to have no drive letter. Right click on the volume and change/assign a drive letter. :relieved:

1 Like

Hmm Libraries says it’s the F: Drive

Should that do it?

I think the F: is the cdrom part. How big is that drive?

I don’t use Passport very often anymore, but there was a tool to disable that function.

Edit: WD Smartware can disable the virtual cd.

The E drive is the CD ROM, whereas the WD hard drive is F. Sorry, I’m not sure what you mean by WD Smartware can disable the virtual CD? Thanks for your patience! If I have to, I’ll just get a new USB drive to use but don’t want to yet as this is a perfectly good and very new external hard drive so it’s frustrating it won’t just work. Feels like it’s something simple that I’m missing :face_with_raised_eyebrow:

In Disk Management the drive letter is missing.

In Explorer it shows a F: drive, but the size or properties are not shown in that image.

It could be a simple refresh to show the F: in Disk Management also, but I just want to let you confirm that the F: is indeed the 2TB volume. Otherwise you need to assign a drive letter. You could also try to remove the drive letter and add it again!

The reason I mentioned Smartware, is that WD Passports used to have the option to act as a cdrom with installation software on it called Smartware. It is software to, for instance, lock the data volume until a password is given (however, usually not after purchase, but by own choice…).

See below, the drive seems to be showing as F in drive management. And yeah that’s the WD drive I’m talking about. When I try to change drive letter I get a “The system cannot find the file specified” error. The drive works fine normally in Windows I.e if I try sticking a word file on it. All working normal.

Okay. Looks almost good:

  • The partition should not be active (only the Windows partition should).
  • Have you had this drive marked as Windows Backup drive perhaps?
  • This drive has not been connected to another OS before (Chromebook or MacBook)?

It’s weird you get the error if you want to change the drive letter. Drive/volume could be locked or Disk Management is not started as Administrator.

I would first try to mark disk1 inactive or even go as far to clean disk1 completely via the diskpart command environment. Then initialize, partition and format again from Disk Management. Carefully!!

1 Like

Managed to get it working! Changed drive letter to H and it seemed to do the trick. Thanks for your help

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.