Engine program running, but I can't open it

Just got an 8000 and downloaded the engine software. It shows that it is running, but the program is not open. just spins and nothing. I have tried some of the stuff i have seen on here, as i uninstalled, deleted denon folders and such and nothing has fixed it. When i first did it, i stopped the program because I did not have a flashdrive, so no i can’t figure out what is stopping it from showing up. Any help is greatly appreciated.


Does your computer have QuickTime installed?

If it’s Engine 1.5 that you downloaded, it uses QuickTime for audio. QuickTime was widely available and practically on every computer from the factory when Engine 1.x was designed and released. Then last year the computer companies stopped supporting QuickTime.

Alternatively, a new version of the Engine Prime software will shortly be available which will allow the library/database to be saved in MCX8000 format.

It does have quick time. I had it running in the background and was on the site to download the 8000 stuff again and boom, it shows up and starts analyzing 11,000 songs. didn’t stop it because it was up… Will see what happens tonight, when i can get back in front of it. Thanks for your info!!

hmm, I got it to work once, but nothing since. I can see it running in the background, but the application won’t open. I ran a registry cleaner and it found some stuff, but still can’t get the app to open. it’s so weird.