Engine Prime not importing ALL songs from iTunes

This morning, everything was working great. I am using Engine Prime (1.6.0 - can’t update as it’s incompatible with the MCX8000), with a Denon DJ MCX8000, on an iMac (OS Catalina 10.15.7).

I had 2 playlists in iTunes, and this morning (as well as last week), Engine imported them beautifully. Then, I realised a song was not imported (due to it being 16/48). So, I converted the song to 16/44 (as per the MCX8000 audio compatibility guidelines), and here is where everything went wrong.

All i did was add the new song to Playlist #2. After this, Engine has not been reading this playlist at all. It will ONLY import this 1 new song, while ignoring the other 60 songs. I’ve tried everything that I could think of:

  • Made a new playlist with a different name, in iTunes, and put the 61 songs in again.
  • I restarted iTunes, Engine Prime, and my iMac.
  • I deleted the older playlist #2 in Engine, and tried to re-import, but again, it only imports ONE SONG.

Engine also took AGES to re-read my iTunes playlists… I had to “update library” 5 times until it read the new Playlist #2. After reading it, I tried importing it again, but no luck: it imports only that 1 song, and the other 60 don’t seem to be readable (note again: these songs were working fine for the past week).

I’ve got a show coming up in a few days, and panic mode has begun. I would appreciate any help & advice on this matter. Thank you so much!

If you try making a new playlist with just that one new music file in it, does that file play?

Hey Pasha. Yeah, it’s only this ONE song that gets transferred / imported, and it plays. The other 60 songs don’t. I can’t re-analyze or re-import the track info (anytime I click on those 2 options, nothing happens).

Also, i tried importing other playlists, and it doesn’t work. NONE of my playlists are importing.

In the “playlists” section of Engine Prime, the iTunes playlists NAMES show up, but no songs are imported.

UPDATE: Now, Engine Prime is not importing ANY songs… not even that 1 song. Only the playlist name shows up, but it’s empty.