Engine os does not show artwork

I have a problem with the display of covers in prime4. The songs have the cover incorporated but when adding it to engine software (pc) and then to the prime 4, it does not show me these covers. I can view the covers in other audio players on the pc.

I have read other different topic but have not fixed the problem

engine os does not show the covers

Where did the songs come from? Did they contain artwork when you bought them?

There was (probably still is) an issue with artwork from Bandcamp files.

Where is “it” not showing the covers? In the browser, the jogwheel, both?

it is not displayed by the browser or in jogwheel. The songs do have artwork, if I play it in an audio player I can see these, but if I play them in the prime 4 or engine software on the pc it does not show me.

OK but my question was where did the files come from? Was the artwork already in the files when you (presumably) bought them?

These songs have been passed to me by a friend, I don’t know where he got them. But I do know that their covers are included.

I’d pass them straight back.

There are a few legitimate places that can give you trouble on file compatibility. Once you start dealing with files from a friend of a friend etc the number of problems experienced could just get worse.

When I have scored an mp3 without artwork, I use an external software program STAMP ID3 TAG EDITOR. I usually get to see that the name of the song, or the artist is not entered, or is entered incorrectly. It is also possible that something completely different is written. You can then correct that. You can also download the artwork using Google Images and insert and save it in Stamp ID3 Tag Editor. With me, all names are filled in correctly and the artwork in the Denon Prime 4 can be seen where it belongs.

You can download it for free and use it, but I bought a payed version. The program is worth the money. https://www.nch.com.au/tageditor/kb/free.html

solved. I used ID3 TAG, saved the information again, and the artwork appears in prime 4 Thank you.

You’re welcome.


Can you explain more please? did you use a program to resave the files?

confused, but it sound like you got it working!


I had a similar problem. I traced it to some incompatibility with Engine Prime due to the way the tags had been encoded. Resaving the tags solved the problem for me. I used MP3TAG. As far as i remember i loaded the problem tracks and just resaved them to force MP3TAG to rewrite the tags. I read somewhere on the forum that Engine Prime has problem with ID3v2.4 tags, but i did not experience this. I have the tag format set to ID3V2.4 in MP3TAG and the files are read without problem.