Engine OS 1.5.1 stuck on boot

Second issue…

Engine os 1.5.1 installed (from 1.4.1), but the P4 won’t reboot… It stays on Engine OS logo.

Still waiting some minutes in case…

SO… Nothing happens. Just disconnect it and reboot. 1.5.1 logo appears and then nothing (except sweep fx buttons which are illuminate).

Never had any issue with the P4. WHO tested this version before release ??? And it seems there is still no Preview functionality too.

But now, how can I downgrade, the Prime 4 is bricked

After 2 disconnections, trying USB UPDATE… Still alive

I think it is safer to update with a usb Ex-Fat key…

YESSSS it works.


Instead of what way? You don’t provide enough detail

And as for

how utterly ungrateful of today’s release, which has been worked on for months by many denon staff and beta testers and provided two new streaming services which were heavily requested by many as brand new functionality.

Track Preview is questionably useful in some situations on a 2 deck setup but there are significant time saving benefits in NOT using track preview on a 4 deck setup.

1 Like

instead of PC/mac update via usb cable.

Trying on a friend’s P4… We’ll see by cable if it works. Strange, the fonts indicating the effects are different.

Testing the 1.5.1 on P4 live know for an hour… Yes there’s a small visual bug when you switch from small to big… it jumps to the next or previous screen.

Different from what ?

It would be better if you use the structured bug report forms to mention What you are suggesting bugs, as the forms prompt for all the required information

With text aliasing if you prefer.

Anyway… the Prime 4 seems to work fine. Soundcloud is a bit slow with long mixes, it does not stream it loads into memory…but it WORKS well done !

A 1:30:00 minutes mix plays well, no glitch or freeze…
Works with two long mixes from soundcloud.

1 Like

After the update: A white screen is displayed with: Engine Prime failed to start: Error 4. HELP! https://imgur.com/8tAwL4I

Insert a usb key with 1.5.1 update img on it (root, and unzipped).

Power on Prime 4 and maintain VIEW button on… It should start updating (that’s what happened to me)

Is there a contact number for denon please UK it’s stuck on load screen after update!


Scrool down to Europe.

which USB slot?

so… how to force a downgrade/try again when its bricked please?

The first slot, next to the sdcard slot.

Works well. Don’t know but the Prime 4 seems a bit slower in tracks loading.

Except the size font bug (when you switch big/small)it works very well.

found it - power on with eject button held

can confirm issues for me with mac updater - downgrading to 1.4.1 then a usb update did the trick :slight_smile:

Ok, I was able to go back to the previous version (1.4) without any problems. Unfortunately, the error is still there when updating via USB or PC… :frowning:


The issue you’re seeing is something that we’re not familiar with. To be honest, this one is a bit of a stumper. I’m going to see what we can do to resolve this and will be reaching out to you over PM if thats ok with you. In the meanwhile, I hope you’re ok with 1.4 for the time being while we figure this out.

Thanks for your understanding,


1 Like

Ok, please contact me.

Format a usb key in Ex-Fat (with a mac /Paragon or a Pc) Copy the 1.5.1 img unzipped file on it (don’t forget to choose the right file : usb file on USB…)

Power the P4 stucked with the VIEW button pished until firmware upgrade begins.

That’s what works on 2 Prime 4 (Mine and another DJ)

On the other hand, no problem with Prime go update.