Engine doesn't show full liberary

USB is full with songs, and always analyzed by engine. After latest sync to usb, engine doesn’t show all playlists/songs. How To fix?

Hi @Mike_Bootsman and welcome,

In order to be able to provide you with advice, quite a bit more information is needed. Can you describe your workflow? Do you work with external USB? Do you manage your collection on your computer’s hard disk or on the USB itself? What steps have you taken? Which versions do you work with?

Hi @addie , thanks for letting me join this platform.

In the older versions of Engine Prime (v1.x.x), i made a mistake and created my full library/collection directly on my peforming USB. I’ve never changed this. This way my library was only visable when my USB was connected with my PC.

With the current version of Engine Prime (v2.2.2), it was possible to import/export my library with the sync tool. Just to be sure, I imported my full collection from usb to pc, so it can be available on my pc without plugging in my USB. Unfortunatly this didn’t work (i don’t know why tho). Library still only available when usb is connected. I also made back-ups with the back-up tool of version 2.2.2. I also made back-up by simply copy pasting my USB to my internal drive.

What happend last week: for a gig, i downloaded just a few extra songs. I dragged them to the desired collection-playlist on internal drive, with my usb plugged. I let Engine analyzed them, I made my cue-points. To speed up the sync proces to my USB with the build in syncmanager, i only selected the collection-playlist where i’ve added this few new tracks. I don’t know why, but Engine had a hard time syncing this, so i cancelled the task. After this cancelation, my collection wasn’t complete anymore.

The strange thing is that all my tracks are still available on my USB when I browse trough the thousands of folders on my USB. But Engine Prime and my SC5000 only see a few collection-playlists.

I’ve already tried to restore with the build-in back-up option. Didn’t work. I’ve also tried to restore the usb with my own “hand-made” back up from my internal drive. Didn’t work either.

My guess is that the other collection-playlists are set on hide or something. I expect to get them visable again when I recover the data-base files on my usb, but i’m a bit to scared to try by myself. Maybe someone here knows a (better) solution?

thanks in advance!