Engine DJ not loading playlists!

Just opened Engine DJ (V 2.1.0) on my desktop to load a few new tracks into Collection and a few strange things are happening. :thinking: When I click on collection I can see all my tunes, when I click on a specific playlist under my collection it shows a loading symbol next to the search field and it’s been loading for over 20 minutes now. It also shows there is no tunes in these folders but in Collection it does:

Screenshot 2022-03-17 at 19.29.59 Screenshot 2022-03-17 at 19.29.32 Screenshot 2022-03-17 at 19.29.47

I also tried to add a new playlist and after I renamed it it just disappeared. Now Engine DJ has just crashed so I re-opened and it’s doing the same thing again, just loading all my tracks, which like I said, I can see them all under Collection but nothing in the individual playlists, any help much appreciated :man_shrugging:

Screenshot 2022-03-17 at 18.58.44

I’m having zero success dragging and dropping my music into my drive when in computer mode. The music playlists have all transferred from iTunes and Serato perfectly. They show up in computer mode. The tutorial tips video shows the click and drag method into the SSD. When I release the tracks over the SSD drive the tracks are rejected. I can see the tracks and playlists in computer mode.

I know I can add them directly to the drive, but that would be a mess in the long run. Just want to be able to load my music the right way.

I got my Prime 4 early Feb 2022 and still haven’t been able to use in standalone. I’m incredibly frustrated.

@TracyJ @mufasa hopefully will read this and talk you right through it. . The guy is a legend when it vomes to sorting playlist exports. What versions are you using and what type of computer windows or mac??

Engine is 2.1.0 and I’m on Mac

In Engine DJ (Mac), after updating iTunes and Serato, did you add the tracks to Engine collection?

The “sync” from both those transferred perfectly into Engine DJ. Click on each of the icons of iTunes and Serato and the playlists all show.

It sounds like you are missing a step

After your sync you have to add those to Engine collection

Right click on the Serato collection and choose add to engine collection

Before you can export to any performance drive

I did not see what you’re talking about in the tip video with the transfer of music. It shows the music being directly dragged and dropped into the ssd.

So the step you talk about is new and I didn’t come across that info till now.

I will give your instructions a shot.

  1. Refresh Serato collection
  2. Add Serato collection to Engine collection
  3. Plug in performance drive
  4. Drag and drop from Engine collection to performance drive

It’s the same for iTunes and other supported library

Hi Chris. When you wish to add new stuff, the new playlist to export must be highlighted in the box before it will copy across in the export to drive. Anything not ticked in those boxes wont copy across. Cheers scoffie

Hi Scoffie, thanks, that’s not really the problem, I’ve been adding new tunes and never had a problem. The problem is Engine see’s my collection with all my tunes but the sub folder playlists in collection show they are all empty.

Have you tried with a new database?

I am working on these steps now.

Is it normal to have to drag only one song at a time per your steps listed?

Not being allowed to drag and drop multiple tracks.

No. You can do the entire thing

Right click on it like so

iTunes

image

For serato

image

Right clicking as you have shown isn’t allowed for me. IDK why

Import Collection is not found or available for me

Post a video of what you are doing if you can.

I have the denon prime go and i have a new SD CARD and i can’t sync none of my music playlist using the sync manager or drag/drop files. This has never happened before using my prime 4. I’m a software engineer so has anyone verified and tested these releases?? If the sync manager isn’t fully working then don’t release the new version of the software. So the question is how can i sync my engine dj playlist to my SD CARD for my prime GO? This is not acceptable practice in SDLC

@djasync. I know this is sounding stupid but have you checked the write protect tab is off on tbe card. Sometimes it flicks itself on when you insert it. ( learnt from own experience). Then is the card actually showing and in the correct format (done that to bought a new one and assumed it was fat straight out if packet and it was ntfs). Yes these versions are tested before release… Why not join in testing. https://community.enginedj.com/t/fancy-yourself-as-an-engine-dj-beta-tester/40935

1 Like

Yes…I checked and that’s not the problem and yes its formatted as exfat. Can someone from Engine DJ please reply? I can’t sync anything since upgrading to 2.1

Are you on Mac? Did you give Engine DJ permission to access all drive