Engine 4.0 Desktop for PC has an edit/rename/delete bug!

I thought repartitioning and exFAT my BRAND NEW Samsung T9 SSD had cracked it, but no, I still can’t rename, delete or edit playlist content after the upgrade from 3.40 to 4.0 and can’t understand why no-one else has the same problem. Happens on both laptop and desktop on ALL 5 SSD drives I own. Somebody must have the same issues I have???

Each drive has its own music database.

Have you let engine DJ on pc/mac “see” each of the music databases … it needs to update/rewrite the 3.x databases to 4.0 databases

Yes I have. The grey bar at the bottom right of the screen reads the DB/tracks etc. I’ve been with Engine since 2020 and never had a problem as bad as this.

The collection and DB are all on the same drive but tonight the collection is not showing (on the left) but the playlists etc of the D drive are showing on the right hand side??? It makes no sense?

And there’s a separate db on each and every drive. It gets out there during the export playlist task. Have you “grey barred” each of those other external drives to update their databases too ?

Yes I have. Just to recap I have been happily using Engine since March 2020 (after 8 years of Rekordbox) and consider myself to be quite proficient with it but I am convinced there is a bug. I’ve never had an empty collection on the left Window pane but fully populated on the right “Drive tree” pane??

I had to manually drag all the folders to the left pane to populate the tree.

Just did all that yesterday without any problems.

Are your DB files write protected for some unknown reason?

This is what I’m thinking BUT its too random. As i said, 4 years experience of Engine but never had such a catastrophe as this?

I’m going to setup a second spare laptop with a virgin SSD and see where that takes me.

I’m rolling back to 3.4 - the desktop 4.0 software just keeps saying my library is corrupt and deletes it - on the 4th attempt of reimporting the files I’ve now given up and rolled back until the bug is fixed

1 Like

6 days I’ve been trying to sort it. I also went to 3.40 and rebuilt a collection library from scratch. When I inserted into the Prime 4+ it migrated but I still can’t desktop edit, rename, delete or add to the collection. I haven’t tried going back to 3.40 on the Prime as I think the OS is fantastic - it’s just the Windows desktop that is the problem?

This was reported and some of us are actively working with the dev team to fix.

This bug is not great at all :frowning:

1 Like

I would advise against mismatching versions as database Schema differences can cause problems.

1 Like

I have the same problem. It’s impossible to have my complete music database on my harddisk. Always corruption… :frowning_face:

Have you tried an SSD instead of a HDD? If not you’re missing out as HDD have spin up and idle times as well as higher power demands from the USB bus? I’ve never had an issue with SSD.

I only get corruption issues with USB thumb drives - even Samsung 3.2 premium ones. I just pull it out and reinsert and it works fine - untill the next power up :roll_eyes:

Changed the title for search-ability

I’ve reverted to 3.3 for both engine and firmware until this is fixed as it’s unusable currently (I’m on an SSD not a HDD)

How do you revert? I always get message it’s not possible due there is a newer version installed…

1 Like

You could uninstall whatever version you have and install the newer version. Have you tried that path? :slight_smile:

on Mac I use appcleaner to remove the newer version, on windows you’ll need to uninstall via control panel/settings - apps. Firmware is via cable and the firmware from the engine download site archive (not usb)