Engine 2.0 beat grid issue

Just updated my system to V2.0, and the install was fine. Started mixing tracks between the layers on a single sc5000m and the beat grids are not working correctly. In 1.6.1 when you have matched the bpm correctly the beat width of the a and b layer match, in the new release they only match by the play head indicated by the white line, and either side of it it looks like the grid shifts making it look out of time. Is there going to be a hotfix to correct this issue? Loads of others on the Facebook group have the same issue. I’d really like to avoid downgrading to 1.6.1 again.

1 Like

Same problem here mate, I prepare my tracks in rekordbox, when analyzed in engine beat grids are off in every track, I am tired of this, brought prime 4 few months ago and there are only problems with engine software…

Sell every piece of DJ gear that you own. You’ll never find hardware, software or firmware which will get every best grid on point

Mate, I prepare my tracks in rekordbox, im not asking it to create perfect grid, just export it from the rekordbox the right way with cues and grid set correctly. Nothing more, nothing less… If i set it correctly on rekordbox and can play on PIONEER no problem but after export to prime it fucks up almost every grid in my whole library, thats quite a big problem. It is extremely annoying

2 Likes

Sorry to ask but have you selected the “export gird information” check box within rekordbox?

That’s Doubtful

Yes I did… already tried to find solutions but its not working… have auto analysis turned off in ep and export grid checked in rekordbox

I will post some screenshots to show you… In rekorbox everything is fine, import to ep, bpm is off, grid is off and even if i adjust bpm to correct one, cues will be off, it cost a lot of time just to set it on rekorbox now I am supposed to spend another time in ep trying to correct everything?

1 Like

Hi @WhoCares

I just tested on my end and grids from rekordbox were imported to engine dj

  1. I gridded 2 tempo transition track in rekordbox
  2. I exported a new XML from rekordbox
  3. I imported said XML into Engine DJ
  4. Analysed the tracks (I have autoanalysis on)
  5. Played the tracks and they were as i gridded them in Rekordbox in Engine DJ

Perhaps you may want to TEST with a blank Engine Library database

Video here

track I am showing should be 100 bpm all the way. loca Tried exactly like you did on the video and still, ep shows 99.8 bpm grid is off and cues too, this is happening in more tracks if the grid is right cues are off

1 Like

Watch this very great explanation by MMG

For testing

  • Convert 1 or 2 of those MP3 files to FLAC or AIFF

  • Run through rekordbox, put hotcues, grids etc

  • now import to Engine DJ

There is an Easter Egg in 2.0.1 (Engine OS)

Shift + Grid Edit = This will allow you to slide your HotCues enmasse if they are off e.g. the N-Viral track

1 Like

Basically I should spend one hour prep in rb and then another 1 in ep amazing, checking all cues, all grids I should buy pioneer instead… wouldnt have to deal with this crap… Tools from the video are just for mac users I only have windows but thanks for your time…

1 Like

I shared that link so you can get the reason behind the shifts you reported.

Its the limitation of technology unfortunately.

If you are a windows user, Lexicon has shift-correction function as well, you may want to try it for a month.

It’s a powerful app as well and does a lot of things.

That’s 100% your decision fam…

1 Like

Or don’t use RB, seeing as it isn’t Denon’s software anyway?

1 Like