DVS functionality with the Prime 4

Mr Cunningham stated during his demo at NAMM that the Prime 4 supports DVS input, would that be to control Engine Prime, or would you have to use a computer? And if it DVS is usable with the on board Engine Prime software, what timecode input does it support?


The context in that interview was about the already known DVS software like Serato and Traktor.

It would be so cool to be able to hook a turntable into a X1800 and control the second layer of one SC5000…


Hi Max, Prime 4 is DVS ready, so when Serato releases the update you will be able to use channel 3 & 4 for DVS control through Serato.


Recently tried connecting DVS Serato to the Prime4. I quickly realized there are no instructions anywhere on how to do this. Not with Denon or Serato. I have yet to see anyone do this. I’ve contacted tech support at Serato they were confused they kept referring to the Prime4 as CDJ. And Denon hasn’t been able to provide guidance on this either.

1 Like

Does anyone know if it will work with Traktor DVS?

What do you mean? The Prime 4 won’t work with Traktor software.

Serato has support and so does VirtualDJ.

If you just mean the Traktor timecode vinyl, then you can use it for DVS with VDJ.

1 Like

I was hoping that Engine OS itself would become a DVS capable software. Imagine if InMusic built a whole ecosystem that you could stay, perform and create in. Despite all my griping, I am a Denon fan boy from long ago, and the brand still has love in my heart. I would like them to update Engine OS to have this and Ableton link, and then I will truly be on board. Might even buy a Prime 4. I have the Go.

1 Like

I seem to be in the same position, I just can’t seem to get Serato to see the dvs signal from the P4. No documentation or youtube videos on how to do it - Nada, Nothing, Zero, Zip! I’m actually shocked there’s no info on this.

When in stand alone mode the sound card of the Prime 4 is not available for the computer.

I understand this, Im in computer mode, with Serato running & DVS enabled in Serato. But Serato doesn’t see the dvs signal from my turntables. I’ve tried switching the front switch to both USB & Line to no avail. I just can’t get Serato to see the timecode signal from the P4. I can’t figure out if Im doing something wrong or not doing something that’s required because there’s zero documentation on how to do this. Really frustrating…

It seems that Prime 4 is not routing any signal to the computer from its inputs.

First some obvious stuff:

1.) switches on the back of the unit need to be set to phono if you’re using “standard” turntables like the 1200’s

2.) Your SDJ must be version 2.3.1 or higher and the firmware on the Prime 4 must be 1.3.3 or higher

3.) You need to have PAID DVS upgrade, not the one that is automatically unlocked by your previous controller/mixer


Thanks for the reply. The switches I was referring to are the line/usb switches on the front of the P4.

  1. Switches (at the back of the P4) are set to phono
  2. Using the latest version of SDJ and the latest beta version of Engine on the P4
  3. I have a paid version of the DVS plugin. I’m no stranger to dvs & have been using Sdj dvs for quite some time with various mixers and controllers. So I really do understand how to normally get things up & running, but I hadn’t tried using the P4 with Serato yet. Now when I try, I’m just not getting it right. Like I said earlier, the control signal just doesn’t seem to get through to Serato from the P4. Thanks for trying to help. Much appreciated.

Then other than downgrading the firmware of Prime 4 to the last non-beta version there is nothing else to do.

1 Like

Did you switch Serato DJ from INT to REL/ABS

Are you using the channel 3 and 4?

Also check that your DVS plug in is activated - My Products

1 Like

I think you might be on to something here. I never considered that. Perhaps it’s the beta firmware. I’ll try downgrade & let you know how it goes. Thanks for the idea.

I’ve tried it all. Switched between Int, Rel & Absolute. Using ch’s 3 & 4. All my expansion packs are active. Im thinking it might have something to do with the beta firmware as SlayForMoney has said. Gonna try downgrade to see if that works. Thanks for your help though.

1 Like