DN S-3700 tempo slider problem

Hi guys, I’m new to this forum and was wondering if I could get a little guidance as to what I might be dealing with here. Today I picked up a pair of S3700s and the left one has an issue with the tempo fader where even when set to 0 it can be up to 2 + or - % pitch. I might be okay with that but it can jump around without being touched witch messes with beatmatching and is really a great annoyance. Am I looking at an irreparable unit I’ll just have to deal with or is this issue fixable? Thanks guys!


Have you tried switching the platters to see if the problem follows?

No I have not, are you referring to the whole unit itself or just the vinyl disc?

Whole platter assembly, including everything on top of it.

Just swapped the platters to no avail. Could it be the potentiometer itself?

Hi - is that pitch difference showing up on the screen of the player as saying +2% as numbers you can read, or is it just “sounding” faster or slower?

It’s definitely on the unit in numbers

That’s what I assumed but wanted to make sure it wasn’t some common easily solved issue. I might pull it apart and attempt to replace the part but I don’t really want to try disassembling it

Don’t do that. A Denon service center may be able fix your issue with an internal factory reset, which would also rest the deck’s pitch settings/range which should bring it back to 0.

Yeah i don’t want to touch the insides at all at this stage. I’ve sent a service inquiry. Now to wait for a response :grimacing:

Okay! It’s been a little while and I have been contacted by Denon in response to my issue and they said I had to send it to a certified repair shop. I live in Australia and they’re all in America so that was automatically out of the question. I finally came to the decision to pull it apart. If I broke it it was my sorry fault but luckily it all went smoothly. Once I had opened it up I pulled out the sliding pot (which was helpfully on a separate PCB) and blasted the crap out of it with canned air, Put it back together and it returns to zero on zero every time. Unsure wether the air was the causing factor or wether it just wanted a reseat but regardless it is now working just fine. Thanks for all the help you guys offered, will definitely be coming back to this friendly community if I have any other issues. Thanks guys!!

I hope you nothed the part number of the pitch fader in case if gives you problems later and you decide to purchase a new one :wink:

Yeah I did :grin: I’ll be pulling apart my second one too as it’s showing signs of innacuracy (+0.5 to +0.10%) so I’ll definitely make sure I have it

I wonder why they do this. The 5500 does this, as well. The service menu is no help.