DN-MC6000MK2 ASIO not connected issue (VDJ+Traktor)

Helping out a friend here using Windows 10 together with either Traktor 2.11 or Virtual DJ 8. Both give the message there is no ASIO connected. Uninstalled Denon DJ Asio, restarted, Re-installed Denon DJ d/led from the manufacturer website (v1.0.1) using the installer.exe Another reboot, and still not working.

Went over this troubleshooting, incl. updating USB drivers, but still not working. When pulling out the USB-cable or putting it in another USB-port, u see the MC6000MK2 disappear under Devicemanagement + reappear. Same happens under USB-devices. So it’s defo connected.

I can even have sound in Traktor using WASAPI-mode. But the damn ASIO i need in order to use the MIC within Traktor.

I’ve alrenatively used CCleaner to fix register errors but also no solution.

Mind u, it has worked. After a reboot I managed to make it work, (after deinstalling/reinstalling), so I thought that was the solution. So i repeated this workaround, and now I cant get it to work anymore :confused:

Anybody has a solution???

Thanks Kradcliffe for trying to help me out :slight_smile:

I’ve tried deleting them with USBDeview, but it’s not helping. Tried reinstalling all, see video’s and opened USBDeview again. See results:

  1. USBDeview clean up: https://www.youtube.com/watch?v=qZRqwEv0oHo&feature=youtu.be
  2. Traktor + VDJ not working with ASIO + Deinstalling ASIO DENON: https://www.youtube.com/watch?v=dcMpi4DPxBE&feature=youtu.be
  3. Reinstalling ASIO DENON + Reboot: https://www.youtube.com/watch?v=WwJkd7gZkIs&feature=youtu.be
  4. After reboot, Traktor + VDJ still not working + device is showing under Device Managment: https://www.youtube.com/watch?v=IuJFafEa2RY&feature=youtu.be
  5. USBDeview showing new device(s), but also double(?): https://www.youtube.com/watch?v=9IQ7l0vC1sg&feature=youtu.be

Any advice is welcome!?

Ok back!

After installing Windows 10 + 7 in a Virtual environment using VMware Workstation, we found out, the issue with not connecting ASIO wasn’t there. So we reinstalled Windows 10 on the laptop itself after. Then we got the same problem again. Turned out: When you open up Teamviewer, before opening Traktor, the ASIO problem shows up lol. So workaround: Open Traktor before, and then after its opened, open Teamviewer after. Then it seems to work.

Mind you, I was phoned to help, since she had this issue already. So at that moment, I didnt had Teamviewer running.

Ohwell, hope it helps somebody!

Since she’s not living next door, I had to help her from distance. Hence I used Teamviewer to do so.

Then again, She called me, she had issues with her MC6000 MK2 and Traktor, and after that, I decided to take a look with Teamviewer. So I can’t really say it’s Teamviewer. Since the reason why she called me, was becoz of this ASIO-not-connected-issue, before I even ran Teamviewer in the 1st place.

Ok, strange stuff going on. After some Windows-updates that automatically got d/led and installed, the issue came back. She was updated until Build 10.0.17409 I believe, but reverted back to older Windows version, which is at the moment: 10.0.10586 This one seems to work fine.

So it’s defo some issue with the latest Windows… Windows 10 Fall Creators Update upgrade mucked it up? She has filled in the form where it asks why to revert back to older Windows and mentioned this ASIO/Denon issue.

I hope you guys at Denon can update your ASIO driver so it will work with the latest Windows (after Fall Creators Update).