Denon MC 7000 Asio drivers with Virtual DJ

Denon MC7000

Hi Guys,

First post on here. I have a powerful Asus laptop with Nvidia rtx3060 drivers and running the latest version of Windows 11. I also use the very latest build of Virtual DJ. I have the latest Asio drivers direct from Denon installed on my laptop.

No matter what level of Latency I set my Asio drivers, the sound on my virtual DJ through the Mc7000 plays ok for around 5 mins but then has a lot of clicks in the sound. I have run Latency Mon and there is nothing causing any serious problems on my laptop. I turn of Kaspersky antivirus, WiFi adapter and Bluetooth adapter when I run vdj too. I have minimal apps running on my laptop as I have built it to have has little problem with latency as possible. I used to have a ioneer ddj sx2 which never had one single problem on exactly the same set up and software. I am about to send thenmc7000 back to the shop but thought I would post here as one last attempt to solve the problem. I can clearly hear and see this is a better controller than the pioneer but if I can’t get the sound working properly I will have to send it back.

Much appreciated for any help.

Try using asio4all or wasapi drivers instead to test

Hi Stay, Thanks for your reply. I had always heard that wasapi doesn’t have the quality of the proper Asio drivers and Asio 4 all is just a mask over wasapi drivers. I will try this but surely the Asio drivers should work.

Hi Stay, Tried Wasapi, exactly the same . Plays for around 5 mins fine and then cracks in sound. Tried all sound configsnto with internal card set as default sound etc. I am running latency and nothing is returning any page fault.or latency issues. I run my laptop Vis an external monitor but I can’t see how that will count if latency is so low. .I really am stuck as to what I can try next. Are there any Denon tech guys who could maybe help?

Hey @rams1884 - Happy to help here. Our team will probably need a closer look at your situation. Are you able to provide a quick video of what you’re experiencing? You can DM me a link to preview as well. I’d be happy to connect you with a technical support agent so they can take a closer look.

Hello,

I’ve been having the exact same problem for a few weeks. Same controller, same laptop (Asus brand). I have dates approaching and I don’t know what to do…

Je rencontre exactement le même problème depuis quelques semaines. Même contrôleur, même PC portable (marque Asus). J’ai des dates qui approchent et je ne sais plus quoi faire…

Run a latency checker to see if anything is causing spikes.

Thank you for your answer. How do I know if there are errors in LatencyMon? I don’t understand it at all.

Merci pour ta réponse. Comment je sais si il y a des erreurs dans LatencyMon ? Je n’y comprend rien du tout.

The smaller the lines the better your system is. This is my 2020 Macpook Pro i9 and it’s about as good as you get.

Leave it running for a few minutes.

Nothing to report apparently on this side

Rien a signaler apparemment de ce côté là

Try a different USB port or cable. Also try increasing the buffer in the Denon ASIO control panel