Just purchased a Denon DJ Prime Go aand was using it briefly before an upcoming event. I noticed that when I am using my USB drive, I’m unable to eject the SD card as it shuts down whatever is playing on the USB drive…? I’ve tried it 5 -6 times and the same result. I put the USB drive in, start playing a song, mid way through the song I insert the SD card then attempt to eject it (SD card) from the control panel during the song (playing from the USB drive). When I get the confirmation screen to eject the SD card it shuts down the song playing from the USB drive…? Is this normal.? Does that mean if I want to change SD cards mid event I need to wait for a break in the music.? This can’t be the case…? When I reverse the process (play from the SD card and eject the USB drive while tracks from the SD card are playing) no problem. It appears to only stop the music when the SD card is ejected.

Please help. I am using the current Engine DJ software 3.2.

That could be a bug. The tracks are loaded to memory so removing a USB stick etc shouldn’t kill the music.

I’ll have a look into it when I dig my Prime Go out if somebody doesn’t get here first with an answer.

Thanks for the response. I am able to remove the USB stick when the SD card is playing, I just can’t do the opposite. When I remove the SD card it shuts down the music playing on the USB stick. Anyway, I hope I can work it out.

I might run the SD card thru the Engine DJ software again…?

1 Like

Definitely give it a go. The track should be cached to memory so you could have found a bug.

1 Like

@aaaguy can you reproduce this bug?

Are they the usual 4 to 5 minute long tracks?

If there significantly longer tracks, then the whole track won’t load into memory and so pulling the memory stick would stop the music

And if @MrWilks doesn’t get there first I’ll try it tonight.

I’ve just attempted to follow this for the last 15 minutes and i cannot replicate it whatsoever, i tried numerous variations and nothing worked.

Is it possible to try this with another USB/SD Card and see if the problem persists.

Perhaps @MrWilks can attempt when he gets the chance.

I will try a different SD card this weekend and see if that changes the result. Maybe the SD card has a problem…?

It’s entirely possible, backup your database on the add card and USB stick before you start to attempt ejecting, just in case you encounter any corruption.

Hey @AU-DJ - Curious how your drives/SD cards are named. Do they have the same drive name?

they do not have the same drive names