Corrupt Database on external SSD

Hi! I’m having a huge problem getting my collection onto an external SSD. It was on there once, but then it said in Engine DJ Desktop that the library was corrupt. So I formatted the SSD and tried again. After a while, a window appeared during synchronization - The library on the SSD is corrupt. I tried old backups of my collection - same error. I tried other drives - same error. I completely removed and reinstalled Engine DJ, completely rebuilt my collection and had everything reanalyzed, formatted the SSD again and still the same error. I formatted the hard disk according to Denon’s recommendation. Even the version of the collection that was already error-free on the SSD can no longer be synchronized without corruption. I have also checked the databases with the SQL tool and found no errors. I no longer know what to do. I am dependent on it and urgently need help!

1 Like

What’s the make and mod of ssd ?

Also , is your version of Engine on your PC, a matching version for your firmware - eg: not ver 2 engine DJ with engine os ver 3 firmware on the prime

It’s a SanDisk SSD Plus 1TB formatted exFAT with GUID Partition Table.

The SSD is not connected to any Hardware, just directly connected to my Laptop. The latest Engine DJ Version 3.4 is installed. I’m using a MacBook Pro i7.

If your prime units have had 2.x firmware on them at any point then the music database on the drive might be 2.x also , so engine DJ might have left a 2.0 music database on the drive - maybe

I reformatted the drive multiple times. I also deleted the collection on PC and recreated it.

Even with freshly formatted drive the synchronization failed due to corrupt database on the external drive (which does not exist before sync)

Should be Formatted on MBR/Fat 32 or MBR/ExFat I believe

I tried MBR/ExFat already → Same problem

Maybe the latest log file can help? Log_2024_04_23__20_42_20_491.txt (54.0 KB)

Today I reformatted the SSD again with overwriting everything to zero (MBR/ExFat). Synchronization started normally. Just before finishing (around 230GB) the error occurred again. I checked the m.db file on the SSD and it was around 9MB, but there were no entries at all. Integrity check returns no error accordingly. Engine sees the SSD again as empty.

I had the same problem on Saturday playing it said that the songs could not be loaded… I have prime 4 and I have a Ssd of 4 tb

Have you tried exporting to an SD Card or another storage medium just to rule out if the SanDisk SSD is the problem? Not had the greatest experience with these devices - they are cheap for a reason.

Have you checked to see if your unit is actually genuine? SanDisk and Kingsotn are major victims of counterfeiting being sold at retail, mainly on online marketplaces. Try doing the same process with a conventional HD or another more reliable SSD to see if the problem occurs.

On the other hand, you can go to Drives and drag your playlists to the drive, without using EDJ’s Sync Manager. Another thing you can do is, using a computer with a Linux distribution, open the terminal and type the following commands:

sudo fdisk -l (will list the disk drives attached to the computer. Look for yours in the list that appears)

sudo shred -n1 -v -your_drive and press ENTER.

It will physically format the SSD and if it is false, errors will occur. After, format drive with MBR and FAT32 or ExFAT.

1 Like

Hi Guys, i had that issue last month and it came down to Engine cannot manage long file paths. Sometimes you may get one file from your dj pool who the creater thinks adding a paragraph for the name is a good idea.

I updated my my library and it kept failing with corrupt database, I work with multiple platforms, so i convert from one to the other. Other DJ platforms could manage the same file, but engine DJ software could not manage it.

  • It came down to me looking on the library,

  • playlist at a time,

  • drag and drop to the external drive.

  • do a re-analysis, then view the playlist again. If it fail via drag and drop, atleast you now know the playlist to look into.

  • Then via the file explorer, check the file name length.

  • If the file name looks much longer than one that you know that works, rename to a shorter name.

  • Then re-export to ext drive.

  • If already in playlist, and it shows up in red, just re-locate to new name changed name.

  • It took me a while to sort out.

Can you clarify “long file paths”? How many characters, or can you copy & paste the full path + name?

I was just looking into the DB schema and would love to see if I can replicate this.

I feel it is 260 characters from file root, due to that i keep file names around 80 characters max, so it understandable. I just compare the filenames to other working file I use and keep it to that size or less than that.

I’ve been having this exact issue for a while now, with USBs and SSDs. I think there is a fault somewhere to be honest. I was the same as you, had everything analysed perfectly, and then one day (18th June 2023, to be exact, I don’t know if that ties in with an update) one drive corrupted, and since then I’ve been battling to try and get stuff organised. I’ve posted about it a few times and I’m just told its my workflow, which it isn’t, because it doesn’t matter which way I do it it gets to a certain point and just stops.

I’ve effectively got a load of music I can’t use because I can’t analyse it and therefore can’t search for it.

It’s not your workflow. I’ve used samsung t5, samsung t7, and sandisk ssd’s over the past couple years and experienced engine dj/prime hardware corrupting them all, multiple times. Sometimes it happens in the middle of organizing playlists in engine dj, sometimes it happens in the middle of a gig on my sc5000’s.

Yesterday I managed to synchronize the entire library to the SSD. I don’t know how. It worked all of a sudden. However, I now wanted to synchronize the library as a backup to an SD card and the error occurred again. I can therefore rule out the SSD and file paths as sources of error.

I have also tried synchronizing individual playlists. Playlist 1, 2 and 3 worked without any problems. Then Playlist 4, 5 and 6 and the problem occurs again. Then I first synchronized Playlist 4, 5 and 6 without any problems. When 1, 2 and 3 are then synchronized, the error occurs again. So it doesn’t seem to be due to corrupt files or file names. It is extremely strange.

Me and a buddy had the same problem. We both had an external SanDisk extreme portable SSD and that caused the problems. Even on a gig we sometimes got a “Corrupt Database” in the middle of a gig.

Now we moved to Samsung T7/T9 and it works for about 1 month without any problems for both of us.

You can google for “Sandisk SSD portable problems” It occurs with SanDisk and WesternDigital.

I wonder if your computer’s storage is the source of the problem? I don’t have this issue at all and have been using Engine DJ since 2017. :frowning: