Channel or firmware issue with MC6000 mk1

Hi folks. I’ve got an MC6000 mk1 which has always worked perfectly but now I’m having issues with channel 1 on it. I’m currently using the mixer disconnected from a laptop with external sources plugged in, and channel 1 is always on – sliding the fader down does nothing. The gain and other controls still work fine.

The weird thing is that when I move the crossfader over to the other channel, the sound for channel 1 disappears – but then slowly brings itself back up to full volume a few seconds later. All other channels work fine, and the same source works fine on other channels.

The odd behaviour is making me think it’s a software/firmware issue rather than a hardware issue like a broken fader, so I’ve tried to update the firmware – but this is proving very difficult in 2018. It requires using Java with an added extension and I’ve been able to get this working on MacOS El Capitan.

Is this an issue anybody else has encountered? Is there any way to reset the existing firmware somehow? Or any other way to update the firmware? Or does anybody know how to copy a .jar file to the Java/Extensions folder in El Capitan (my Mac is blocking every possible way I’ve tried to do it!)?

Thanks in advance.

Make sure the switches on the back of the unit are set properly (INT mix/PC mix). It has been stated numerous times here on forum and otherwise - do not put an existing firmware version on your unit unless you’ve been directed to do so by the support. Each time you risk locking the unit in case something goes wrong with the process.

If you have an older firmware version - yes, update it but don’t expect it to solve the problem

1 Like

Thanks for the reply. Pretty sure I’ve got the switches all set correctly as it’s worked fine until recently and the other three channels are still behaving normally, but I’ll double check later.

I can’t see how to check the current firmware on my device - if it’s the latest version then I’ll follow the advice and leave it well alone, thanks. Is there a way i can check without doing the whole Java business?

Hi, morning guys been Ding since 87’ but fresh to controller world. I got this mc6000mk1 using Traktor pro 2 for a while now but, all of a sudden cannot get set up right after firmware update to latest of Denon site help. In settings panel I have output routing is external, mixing recorder internal… everything works fine but not recording any audio or sound levels in recording meter until I switch output routing to internal then does show recording then no sound… is it the windows laptop or denon controller? any help appreciated.

It’s your Traktor settings or the switch on the back of mixer (INT/PC mix). Take screenshots of Traktor Preferences: Audio, Input Routing, Output Ruting,…, upload them to a eksternal site them link here.

1 Like

I have been using a macbook forgot to switch to windows setup but…thanks for tip.

I have a mc6000mk2 and yes i have trouble with the volume fader on channel 1 my problem is with moisture and dirt. So waiting on a fader since April. The last update firmware update was 2018 there our no more updates.