Cant sync files to usb drive

Hi, I have been using my 5000s and x1850 no problem. Yesterday I plugged my usb drive in to transfer some more files over. There was none of the already transferred files visible on the drive and I cant transfer anything across. Ive tried 3 drives, all formatted to FAT32, one drive is brand new. Running 1.6.1 prime software on 2013 MBP. Only thing that has changes since I last did this is that I am now on 11.5.2 Big Sur on the MBP.

When I try to sync the files, the blue bar scrolls for a few seconds, as in it looks like something is happening, but there are no files on the drive. Ive tried all the different ways to get files onto the drive but nothing shows up. I cant create any new playlists or collections on the drive pane either.

Any help would be much appreciated!



Hello @TommyF Welcome to the forum.

How much tracks did You want to transfer? Did Engine created a Engine library folder on that drive?

Hey @TommyF Sorry to hear about your issues. If you need further assistance, we’ll be happy to connect you with a Technical Support agent. Shoot me a DM and we’ll get you sorted.


Hi @NoiseRiser, thanks for your reply. Initially I was trying to transfer about 10 playlists with about 10 songs each. When that wouldn’t work I just tried 1 playlist, still nothing. And yes an engine library folder has been created on the drive.