Cannot update Prime 4 to any 2.0 engine OS

Hello all,

Been searching for ages and found nothing specifically suitable to my issue:

I have recently purchased a Prime 4 controller, started mixing and then noticed there were updates available, it was initially on 1.62.

Updating via USB to the latest at the time (2.2.2) went well, everything was updating and the machine shut down after a few progress bars detailing progress for controllers and software and filled up.

After waiting for a few minutes I then rebooted the device and noticed it froze just as the ‘Engine OS’ boot up text fades out and the library is revealed, like halfway between.

It then cut to this screen: (cannot upload photo due to being a new user) This screen: UPDATING… PLAYER WILL REBOOT AFTER UPDATE DO NOT POWER OFF

        (Single progress bar) Updating Mixer to 01.48

The problem is, this progress bar never fills up, the device shuts down after 10 or so seconds, and the cycle then repeats when I boot it.

I tried every single edition of Engine OS 2.XX staring from the oldest and working my way but with the same result…Mixer 1.48.

Downgrading to 1.62 allows me to carry on but I really don’t buy and form of kit to run on old software.

Funnily enough, I hoped that 2.3.0 would solve all my problems but it gets stuck on the same screen saying ‘Updating Mixer to 1.50’, big sad.

Tech support told me to update the device by following the online/manual instructions which clearly at this stage is useless so I’m hoping to find some sense in the forums!

Hopefully this is detailed enough to explain my problem fully in order to find an answer, and to help anyone in the same sinking boat that I am in right now.



That’s a shame. Have you tried to update to a version that’s a halfway point, like 2.0.0? That should also update the mixer firmware but will be a lower number.

I think from memory there was one around that time as it seems this is where the update is getting stuck.

Maybe it needs that lower mixer firmware first.

Just re-tried it in case it tripped it into operation but the same problem occurs.

I think it’s one for support then.

Hopefully they can fix it for you pretty quickly as you’ll enjoy being on the V2 firmware.

Yeah lets hope they sort it, so far they’re taking over a week to reply to my latest response and just asked to me to what I explained I’d done…I’ll get there haha.