Cannot play tracks in computer mode with Serato


Please help me out. I’ve been trying to prepare my tracks in computer mode with Serato Pro (latest version 2.3.2 Serato and 1.4 Prime). Everything loads fine, I can see hot cues are loaded, songs load instantly but when I press play on either deck nothing plays. Whether I play from the controller or computer I cannot see the song play however I can see the button has been pressed due to the animation in the software when you press cues or play button.

Has anyone else experienced or solved this issue?

Thanks in advance.

1 Like

Check that Serato is in INT mode and not REL/ABS

Yes thanks that worked! It’s not the most intuitive setup.

1 Like

Where can I find it? in serato

Just beside the virtual decks

I cannot for the life of me find any place to change the mode. Tried the F3 and F8 keys, as told to do in a tutorial. Doesn’t work. Man there are so many things to figure out on this Prime 4.

image image

There you go

My version does not have that drop down. Also, on top right - MIDI is blacked out so I can not select that. Ugh.

Are you having any issues connecting or using the Prime4 with Serato?