Bug: Waveform grid lines do not extend to the bottom of the screen when in horizontal mode. Engine Os 2.0, 2.0.1, 2.0.2, 2.1 and 2.1.2

I don’t do these things… so if someone wants to direct me to the right spot… Cool… I’m here because Denon hasn’t addressed my issue… and I’m wondering if anyone else is experiencing it and if so or not… how do I combat this bug. It all started on 2.0 EngineOS it also is on 2.0.1. My issue or problem is when I load more than 2 decks at a time, my waveforms get cut off. It doesn’t matter what decks are loaded… it’s when there is more than two that are loaded that this happens. It’s super frustrating… looks like the software is in beta or something… I dunno… what can I do? How does one reinstall or maybe delete the engineOS? My friend isn’t having these issues… I feel the issues are due to Denon trying to squeeze as much (in my case useless features) onto a tiny screen. Is there a way to remove all that? Plz help… I can’t upload images to show the issues because I just signed up for the forums.

Processing: 20211021_221657.jpg…]() Processing: 20211021_221458.jpg…

1 Like

Do you mean “more than two decks” or “more than two layers” ? Do -all- the waveforms go missing on all decks, or do they show on the deck which has the library drive connected but don’t show on the remote/networked decks ?

Also, it would be good to know some specific details, so it would be best if you could fill out the Pre-laid out form in the Bug report section of the forum.

It may be that someone’s already written this same query already on a form, in that section, which means you could just add your extra detail to that existing report

I would like to upload a image.

Disregard that red edit circle… I was showing a friend a tab in the center. Look at the beat grids

Image 2 is correct and shows no issues… and I believe layers is the word I’m looking for … when there is 2 decks loaded or layers… everything looks great . As image two shows… image 3 is when I add another layer/deck.

Image 1… you see the beat grid… just going outta wack… like it decided to just shorten itself due the how the size of the waveforms are

I shouldn’t of said waveforms… Sorry. I meant beat grids. You can see in image 3 the issue… image 2 and 3 have the same tracks loaded… only difference is image two I only have two decks loaded… image 3… I have 4 loaded

Yes, I see the issue. Some of the beat grid lines are shortened. Also the blobs at the bottom of the grid lines are missing in the last image.

Is there a way to remove all the track info? There is so much stuff added that it just doesn’t fit on the prime 4 screen… least not mine… example the new “lead, sync” display… I feel the more that’s added… the worse this is going to get. Also the waveforms shrink dramatically when you add layers/decks … more than 2. If possible I’d just like to have none of that extra stuff… Or make it so we can hide it.

Here is a image of the full screen. To me it seems there just inst enough real estate… image 4 … now notice the size difference from image 5… image 5 will be just two decks loaded. FYI between these pics… I did not reset anything… in image 5 I checked disable decks 3/4 … here you will see the shortened beat grids… however now they all show up and are not cut off… but still why are they shortened like that?.. and the last image… image 6… I am going to reset my prime 4 and only loads tracks into two decks (1/2) and you will see that everything looks great and fine. Now let’s say I cross the decks and do like 1/4. that is what image 7 will show, you will see now it changes position of what beat grid is cut off…

DURING those troubleshooting steps… I have noticed… if I change my order of what decks are loaded at the first moment the unit is turned on… meaning do not load decks 1/2 … but do 3/4 first! Then I won’t have a issue. Here that shows in image 8… Denon can you plz fix this… I’m glad I was able to find a work around… but yeah… definitely seems to be a bug!

+1 I’m having the same issue on my Prime 4. Please fix this! It makes the grid not just useless but actually misleading :confused:

1 Like

@rajivchopra1827 … try loading decks 3/4 first at the beginning, then do 1/2. You can see from image 8… everything loaded right. But you gotta load deck 3/4 first on boot up of the unit

Interesting, but annoying bug. Have you tried to:

  1. go to full 4 deck display
  2. go to settings
  3. About/Update
  4. Reset to default

maybe there are some hidden settings from previous firmware. If you do this reset - all variables should reset to default. (And maybe the bug is gone.)

But - yes! - This bug should be adressed by denon as soon as possible. For myself I didn´t see this bug on my player. Have tried some combinations of load, but never come to this issue.

have the shorten beatgrid now also, can confirm this bug - it seems to start, when you turn off the other players (2-deck mode). not allways but often. - in 4 deck mode everything works fine.

I’ve been fooled :astonished:

Looking at these pics I got all excited because I though Denon had finally added artist and title back to the decks - but no, it seems they haven’t done so.

I’m guessing you renamed your files to compensate.

1 Like

I think he has tagged it: Artist in Artist Tag field … and Artist - Title - in title tag field.

hmmm … :face_with_monocle: not such a bad idea … for the moment :wink:

1 Like

I’ma try that reset you mentioned. I didn’t know if there was such a thing. I was tempted to try and hard reinstall the OS but was worried I’d loose my work… kinda like how 2.0 scrapped all files and moved them into a folder called database2 and placed history in a folder called “older” and reset all beat grids… Oh man did that urk me so bad…but that’s bridge under the water… I was just glad I found the “older” folder… I just don’t like that it reset all my beat grids . So ones that were off . That I fixed . Went back to being off. … then this whole ordeal happened with 2.0.1. my work around I’d to just load decks 3/4 first… long as those are loaded with tracks first and at the very beginning of when I turn on the unit… then I’m good rest the time… and everything plays and loads as it should

1 Like

The reset in about/update is only for the hardware settings. nothing of your music is changed.

1 Like

I did find that. I don’t think that will do anything… do you know if there is a way to hard reset/reinstall the OS? Like say the chance my Install was bad and or corrupted… how would I install again?

Also if waveforms are vertical… no issues at all… it only seems to horizontal

If you want to use your Prime 4 with only two decks you can do this in the settings menu, or you can press the SHIFT + 3 (or 4) button that allows you to change the deck. That way you no longer have decks 3 and 4.

Yes, it’s a BUG and it has been reported, you can’t do anything. It occurs when you switch from vertical to horizontal view with 3 or more decks loaded.

The only way to restore the two (horizontal) waves with normal view is to momentarily switch to 2 deck (as I wrote above) and then return to 4 deck mode (if you want).

Djaj… you can also do that Inside the menus. That’s not the issue. But thank you.

I’ve updated the title to better reflect the issue.

1 Like

Look at the waveform above in this image:

Is this your problem?

One of them yes. That error happens from when you click the disable decks 3/4 after you have loaded deck 1/2

Also these issues only happen when you are in horizontal mode… if you are in vertical… there are no issues

Yes, it’s the same problem like this: LINK

And it’s the same problem that I had too. :wink: