Bricked X1850

After unsucessefully attempting to update X1850, I ended up with a now ‘bricked’ mixer. I downloaded the Windows driver, then the actual update d/l. For starters I had to manually get the ‘Downloader’ icon to open said downloader. Denon certainly left a lot to be desired with regards to no providing more concise instructions on how to launch this spce vehicle (which is what it might as well have been considering the complexity thereof!!) I connected USB to #1 port on mixer. Powered up by pressing the 3 buttons, got the ‘do you want to update’ message said ‘yes’ then saw the mixer say erasing flash…etc etc. Then data receiving, It said there for at least 15 minutes…then restart…which I did and got the Christmas tree/wave lights. which went on for far longer than the usual at startup, and did not stop. Figuring something was ‘not right’, I turned the power off. Turned it back on, again using the 3 buttons…then when I opened the uploader utility I got “Firmware Update File Missing, or Invalid” So basically I’m intercoursed…(really wanted to write the actual state)

It’s not bricked, most likely you just need to force it into update mode and try again. The newer generation of Denon DJ hardware has firmware not on EPROM chips but on some other type of memory enabling users to try again in case of failure.

Lost track of how many times Ive retried! The mixer’s ‘flash’ has been erased…or so I read on the mixers screen…so I assume there is no ‘software’ to update since it was erased. The So I’m completely lost! The Denon DJ Driver Control Panel window on my PC screen that shows the ‘connection’ is very vague and only shows “Hardware Connected”. The mixers screen shows “Data Receiving” but the Control Panel Window on PC shows “Not Streaming” The thing just ‘sits’ there. I’ve let it sit there for over 15 minutes, turn it off and when I turn mixer on again…I get the continuous wave and it never really powers up. I even tried Factory Reset. Nothing. Im lost!


It is a fatal error to disconnect the power during an update, if this takes a long time according to our perception it is better to let it continue even if we have to wait a whole day because disconnecting it is usually a bad idea even when updating it is good to connect it to a UPS in case perhaps

Even if the flash is erased you should be able to start the update on the computer again. It might need another USB port, as it went wrong the first time already. If you can, try another computer entirely. Preferably, don’t use a USB hub between computer and mixer.

Tagging @Anthony_DDJ in advance.

If That’s the case…guess I’m not only lost…but screwed as well.

You’re commenting only from an old legacy mcx point of view. It’s considerably more difficult to “brick” more up to date, modern tech like prime.

Gents, seems to be solved through DM contact. :slight_smile:


Reese suggested something and it worked! For some reason my PC did not provide the propper installation window for the update. Reese suggested I got straight into the c:Program Files (x86)/Denon DJ X1850 Prime Firmware Updater.exe folder and execute from there. Immediately a different window popped up that recognized the 1850…and I followed the prompts…and VOILA! After several hours of frustration…problem solved! Reese is my hero!


I had a laptop that just kept on failing to do the update tried another one and it went through first time worth trying if anyone has similar issues.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.