Bricked Prime 2

It would seem my Prime 2 is bricked. Is there any way of unbricking it?

I can download the updates to the unit, but the unit will not update to the version I’ve just downloaded. I wanted to upload a video of the unit starting up but the file is too big. What happens is, once the unit has gone through the boot-up process, all of the LEDs stay lit up apart from the VU LEDs in the middle of the mixer but these light up when the unit is booting up. Any help to get this unit working again would be greatly appreciated.

Hi @djcraig,

I think you’re better off contacting support by creating a ticket, as I don’t think we as a forum can really help you with this. Support | Engine DJ

1 Like

Have you tried downloading and updating via a usb stick.

Aye, ive tried that too. :frowning:

Have You tired update via USB cable from PC/Mac?

Tried all the usual ways of updating, none of them work. I suppose I can download the update to the unit, but it just won’t run.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.