Brandnew Prime 4, Waveform displayed incorrectly

My Prime 4 arrived today.

Unfortunately, after updating the firmware I noticed that the waveform is out of sync with what is played. I used the 1.4.1 firmware update and simply put a USB stick into the Slot 1 with some music on it (no pre analyzed tracks or something).

For example, I can hear a drumroll, but after about 8 bars, I can see the drumroll. The moment I see the drumroll, I can hear the base starting to kick, but the base comes 8 bars later in the track, so I see the drumroll but hear the base because the drumroll is already 8 bars gone at that time. This happens after some time in the track, not at the very beginning.

I noticed 2 out of 10 tracks I played are displayed incorrectly.

Can someone confirm / reproduce this?

Edit: In addition, I noticed another strange thing here. This is with the track I used to produce the above issue. I skipped back to the very beginning of the track, where a 4/4 drum (just kick and a bit of bass, nothing to fancy) is. After a few bars, the waveform is suddenly out of sync, like … the wave shows the bass 1/2 bar before than it actually is. I have a screenshot, but I cannot upload images as new used unfortunately.

Happened to me also, it seemed like the track I was playing had another waveform? I just deleted the track and had to re-analyze the track then import it back into the Prime 4.

So you think this track was mis-analyzed by the device?

Possibly, just delete the track from Engine Prime and re-import it. Should fix the problem.

No need to reimport, just re-analyze.

1 Like

Also I wouid reanylise using mac or pc on prime 1.5 then transfer into usb. I have a new prime 4 that came today and I’ve done that with little problems. Grid off here and there a little but that’s digital dj life. I have come from Traktor and on alot of old skool stuff engine prime 1.5 does a better. Enjoy ya prime 4 :sunglasses:


Thanks. Well, it is really unfortunate, because when just pluggin in a stick for a quick set here and there, having off beatgrid and everything really su***.

How can I tell the Prime4 to reanalyze the track? I did not find anything in the settings or the manual…

Re-analyse - this You need to do on Your Engine prime on the computer.

The current version of the Prime 4 firmware does not have the fancy new BPM algorithm of the Engine Prime v1.5 computer software, so it is using the older algorithm which is much less accurate.

You can either analyse tracks using the computer software, then transfer to a USB, or wait for an update for the Prime 4 which includes the new algorithm.

Nice. Is there a timeline when the update for the firmware will be released?

Not sure yet when, but I bet it’s not really far away now, since we have the computer software updated. Probably some beta tests and tweeks and will be good to go, or a bit more coding needed so I would count from some weeks to maybe 2 months??

1 Like

Sounds awesome! I just played 2 hours straight with the brand new device and it was a breeze! Awesome “workflow” (if you can name it that). I have not more than one year experience with DJing and I already feel comfortable with the new controller!

Thank you Denon for this awesome piece of hardware.

In the case of the slow waveforms have you tried a really fast, branded usb flash drive. Some of the flash drives around are slow - it mightn’t make a jot of difference, but it’s worth a try

Well the problem is not that the waveforms are slow, the problem is that they do not match the actual sound!

The post seemed to suggest that things that were heard were then seen on the waveform a few seconds later - sorry if I interpreted that incorrectly. I was thinking of the issue like I think of lip sync on old films, or when virtual DJ tries to play back music videos

Yeah. So I just had a look on my screenshot again (Yay, I am now allowed to upload images!) And you can clearly see how there’s a base for two bars and then a short silence with only a bit of a hithat or something, then another base and after half a bar that’s cut off. But the sound was actually like you’d expect, which is a simple 4/4 kick loop like you can see in the first two bars here.

After that, the waveform is of course out of sync with the actual sound.

Ok, that is an issue I had some time ago. Take Your tracks back to the computer and run second analysis on them in Engine Prime. There was probably an error during waveform build that caused this. Second analysis fixed that issue at my tracks, so try it on Yours too and let us know if it worked.

okay, next issue: I copied music to my HDD and installed it in the Prime4, but when booting the prime4, it does not detect the crates. I can clearly see the music files and also play them, but in the crate view, they are shown without title and everything and there are no crates shown.

How strange is that?

How did You coppied the tracks? Export By engine prime or Just copy by explorer/finder?

I just copied. I figured out the problem already, but did not find a solution yet.

The problem is that the software on my computer exports in an old database format and the controller tries to upgrade the database but fails to and the DB then stays in an intermediate database version. Export is in DB schema version 1.7.1, controller upgrades and gets stuck in 1.8.1 and a new DB when inserting a blank drive is 1.15.0 - so the controller fails to upgrade the database.

Thus, I have to hack my software to export in 1.15.0 and everything should be fine.

(Just to be clear: I’m not using the Engine Prime Software as I am on Linux here and am using a development build of mixxx - so this is all on me here and I cannot expect any futher support from you guys, which is fine, of course).

Still, smaller exports (only a few hundred tracks) with mixxx, which obviously also end up in DB schema version 1.7.1 can get upgraded by the controller. Only my “export all music”, which results in about 56GB of files and a DB that is somewhere near 600MB fails to be upgraded by the controller.

Thank you all so far for your support, I really appreciate it! :heart: