Beatport Link will not connect on Prime 4 but working fine on Prime Go

I cannot get Beatport Link to login on my Prime 4, but testing it on my Prime Go it works fine.

The issue is that I get this message that says it cannot connect to the internet, however WIFI is working fine, all other apps including Tidal connect fine, and my Prime Go which I am testing with it sitting right next to the Prime 4 is connecting to Beatport Link fine.

I have updated my Prime 4 to the latest version which is 2.3.2 and there’s no change it is still not logging me in and showing me this message.

My Prime Go is still on 2.1.1 because I rarely use it and am reluctant to update as every time I have updated in the past I experienced some kind of issue after the update.

Has anyone come across this and know what the issue is with my Prime 4, I really need to get Beatport Link working?

Any ideas anyone, really struggling to work this out. I have messaged Denon support directly and Beatport directly, no reply as of yet!

I’ve a same problem with Beatport Link & Beatsource Link. Engine DJ OS 2.3.2. SC5000 Prime and SC5000M Prime Tidal, Dropbox and Soundcloud works great. Come on Denon guys let’s do something

Is the issue for you on the Prime 4? Do you get the same error message I posted in the photo above about not connecting to the internet?

I have a Prime 2 unit and I’m having the exact same issue. I’ve gone through all the support forums, resetthe unit, checked wifi settings, connected LAN cable directly and even tried Hotspotting and I get the same error… Very frustrating considering I just renewed mt beatport link subscription

Forgot to mention that this is after upgrading to 2.3.2

Has anyone received and luck on this? @luke_gray Did this happen after your subscription expired? My card changed and my subscription ran out. After I added a new card and started my subscription back up it won’t let me log in.

Just became an owner of a Prime 4 after years at Pioneer. I really want to use the streaming services which are (told to be) available. Since I’ve found no complete solution I started digging around. The issue appears after version 2.0.0 it seems, so I started downgrading from version 3.0.1 to 2.0.0. In the meanwhile I started my networkscanner to see what the device was doing, unfortunately there is no clue on what is wrong with the later firmware versions.

I ended up in version 2.0.0, login to Beatport and then upgrade to 3.0.1. The procedure borrowed from another topic.

  1. Copy the xxxx.img file to the root folder of an exFat or Fat32 USB drive.
  2. Eject the drive safely and insert it into your device.
  3. Power on your device.
  4. Open the Control Panel by swiping down from the top of the screen, then navigate to the ABOUT / UPDATE tab.
  5. Locate the UPDATE FIRMWARE section and tap the word REBOOT
  6. Confirm that this is the correct version you want to update to by pressing yes.
  7. The device display should now show update screen the following text: Updating… Player will reboot after update. Do not power off.
  8. After the update is finished, the unit will reboot with the new firmware. It’s advisable to power cycle the unit again manually before use.

The files are a bit hard to find but are located at enginedj download section. I can’t post links as a new user…

Keep in mind that whenever you need to re-login to Beatport again you might need to repeat this procedure. For this sake I strongly recommend to keep the firmware nearby on a USB drive for example. I read someone who lost his login after a creditcard expiration and this caused new login requirement.

Hopefully this helps someone who is having the same issue. Apologies for no URLs, new users can’t post hyperlinks as stated before.

In Engine OS 2.4.0 version they finally added the “factory reset” option that clears all streaming services login data. That should fix any issues similar to the OP, I do not believe it is necessary to go through this rather long, convoluted process of downgrading/upgrading firmware to achieve the same result.

Unless of course that option did not work for you.

Thanks for your input in this (rather old) topic. To make things clear I had a brand new Prime 4 (which came of the factory) and did not work with Beatport. After further investigation I noticed that version 2.0.0 connects to When a newer version gets installed it connects to which is different and could explain the issue. I’m going to investigate this further for analysis and hopefully to find the root cause.

All you needed to do is do a factory reset in the lastest firmware for Prime 4 and after that enter your login credentials for your beatport account.

Not sure what you think you can accomplish by “finding the root cause” when the solution remains the same: clearing all streaming data using the factory reset option in the settings.

Because Beatsource uses/used Beatport as backend. You could also login with your Beatport streaming account to Beatsource.

Don’t know if that still is the case.

In any case: do a factory reset like opted above.

Well, thanks for all your thoughts and inputs. To verify it for my own sake I did factory reset the unit; Beatsource could be logged in to, Beatport didn’t. On Beatsource my playlist etc. were not displayed which I build in Beatport, perhaps I’m missing some knowledge on Beatport in relation to Beatsource. So using Beatsource was no option. The loggin API which the Prime 4 tries to reach Beatport with version 3.0.1 is the wrong API, network packettracer shows this clearly. I could probably fix it using an own DNS server and set the to the IP address of , but for now it works with this procedure. Flashing it back to 2.0.0, logged in to Beatport, upgraded to 3.0.1 and I was good to go. Anyways, thanks again (never expected this quick responses which I really like!) for your thoughts and hopefully it will be solved in the future.

Thanks, then this is definitely something to report to Denon developers as a bug if factory reset option does not fixes this kind of a problem.

@AIRVince this might be worth sending up the chain

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.