Beatgrids for Apple Lossles (.m4a files) not detected in Soundswitch

All my files are analyzed in Engine DJ, but when opening my Engine Library in Soundswitch, autoscript does not detect the beatgrid in my .m4a files. I can manually insert a beatgrid, but that defeats the “auto” in autoscripting. Is this a current limitation?

Strange. Seeing as soundswitch support m4a

Do tracks play ok??

Yes, they play fine. I have to manually set the beatgrids for m4a files. MP3 file’s beatgrid gets detected just fine and get autoscripted. All m4a files get skipped.

Kk have the tracks been gridded in say engine or serato. If so can you use those as a workround.

Yes, they have been analyzed and beatgridded in Engine DJ. Soundswitch sees the beatgrids in MP3 files, but not M4a files.

Here’s a screenshot. The skipped tracks are M4a (Apple Lossless files)

Extend the status tab on the skipped tracks what is it saying “(file has ???)” There is the clue

1 Like

There’s no file type column. I created a separate playlist with just m4a files, re-analyzed all those tracks, refreshed the Engine Library in Soundswitch and tried to autoscript those tracks. This is the result:

Scrolling to the right to see the full status:

Looks like the beatgrids don’t exist or not detected. On your library in Engine DJ are you seeing this (see GRID column below):

These are all .m4a files and I had no issues running autoscript.

Good luck!

And here’s the screenshot from Engine DJ that shows all these tracks have been analyzed.

Are your files AAC or ALAC? Mine are all ALAC (Apple Lossless).

Yes. Here’s a screenshot with the grid column added.

Good point on the ALAC file. I just sent you a message.

Also you can reach out to SoundSwitch directly for investigation at:

hi@soundswitch.com

I’ll email soundswitch. Thanks!

One other thing:

Are you pointing to the same drive/library in both Engine DJ and SoundSwitch? For example: My library is on MIXLIVE 1TB

ENGINE DJ SCREENSHOT:

SOUNDSWTCH SCREENSHOT:

Screen Shot 2022-02-28 at 3.54.09 PM

Yes, I’m using the local music folder. I noticed you’re on MacOS. I’m having this issue on Windows. Going to try it on my MacBook. I’ll report back.

I tried it on my MacBook and it worked fine. Looks like it may be a Quicktime/Windows OS issue. I’ve messaged SoundSwitch Support.

1 Like