2 sc6000 + 1 x1800 - Problems with Engine Connect

Hello friends, I have a pair of SC6000 and an x1800 mixer.

The set works fine but I have a doubt and a common problem happening.

The question is: What is the PC connection in the mixer’s HUB for? I connected it to my internet hub and nothing changed, I thought the players would have access to the wired internet through it, but no! If I turn off the wifi on the sc6000 they are without internet!

The problem is: Engine Connect! One time it works fine, another time the connection between the devices does not appear. The link between them is extremely slow! The tricky thing is that this doesn’t happen all the time but it happens frequently! I usually turn on the devices to play in my studio about 2x a week.

A few days ago this started to bother me! I use 1 ssd of 500gb in a sc6000, so I use it through the Link to another one!

When I go to access it, it keeps loading the songs from the playlists with a very considerable delay, almost 3 minutes to complete and show the songs from a playlist!

Another detail is the Engine Conect screen on the sc6000 screens, 1 of them shows the assigned channels and in another nothing appears! No option to assign channels! Very strange!

What have you been doing when this happens? Thank you for your attention!

Do You have the newest firmware on your devices?

Yes, it has the latest firmware 2.2.2

And what firmware is on the mixer?

The mixer also has the last one that came out for it, 1.6

Did you tried maybe with powering up sequence? Like decks first, mixer last, and opposite way maybe? I read somewhere on the forum, that this at some update had something to do with correct engine connect recognition, but not sure if this is the case still. Try and let us know the results. I will ask @mufasa, maybe he will know a bit more?

have you checked if the mixer gets an IP? you can check this in the depths of the menu and also request a new one.

i have a similar problem.

my hardware 2x sc6000M + x1800 firmware 2.2 and mixer 1.6 mixer is integrated in lan, this works for me WLAN is off hard disk 1gb

power on sequence mixer, player1 and player2 only when loaded switch on the next device

sometimes the mixer does not recognize the bpm, sometimes not played tracks are not or only very delayed displayed as active or played

and one thing i couldn’t adjust yet, the system sometimes gets completely out of step but I am not sure how to describe this

i researched the behavior and came across a tip to lower the pitch level to 4, default is 8 i think this has brought some improvement as the beatmatching works much better but when it really jerks, then it’s more like one player has a completely different speed than the other. According to the displays but not.

@djleh82 i have same set up

My power on sequence

Players first, then mixer.

Hold down the Engine connect button to check both players are connected.

I’m connected via Lan to port 2 and 3 of the mixer.

1 Like

Thank you very much, I will connect the equipment here, I will do this sequence, I will film and post the video here ok! @NoiseRiser @nexon3d thks!

Guys, sorry, I don’t speak English, I’m from Brazil, the video was a little long, so I uploaded it on my google photos, access the link below to see ok!

The Engine Conect problem was solved with the sequence of turning on the players first and then the mixer, as proposed, but the slow reading of the SSD on the link continues! It took 2 minutes of reading until the tracks appeared! Strange because it didn’t take long to do this reading, it was very fast, almost instantaneous after accessing the link. Doing a link search is now unfeasible! Trying to understand why!

Guys, now see what happens, if I turn on the Player that will use the Link last! I turned on Player 2 which has the internal SSD, the mixer then Player 1! He accesses the Link instantly as it is meant to be!!! Crazy this!!!

But when doing this, Engine Connect does not show the connections in the player turned on last. But the Engine Connect functions still work without any problems. I’ll test by turning on player 2, waiting for them to load everything, then turn on player 1 and finally the mixer and see what happens!

It’s raining a lot here, I had to turn everything off so I don’t take risks with lightning! but I did this procedure, connect the player with ssd first, I loaded his ssd with the playlists for him to read, then I turned on the other player and did the same procedure of choosing the internal drive that in this one is a simple hd, then I turned on the mixer, it recognized the link, I chose the ssd player from the link and voila, it instantly loaded the playlists and songs! The only problem is that the ssd player I turned on first now doesn’t show anything on the Engine Connect screen, on the other the connections appear normal. Strange but really in this sequence the problem of slow reading the link does not exist! Fantastic!

Did you try with new Ethernet CAT6 cables ?

I’m using the Ethernet cables that came with the players!

No harm in trying new ones. Stranger things have happened

1 Like

Guys, final test today! And here for me the correct sequence to turn on the equipment was:

  • Player 2 where I have an SSD and I only use his music. I turn it on, wait for the system to load and choose the internal drive, making it load the playlists completely.
  • Then I turn on Player 1, because it will use the LINK to get the songs from Player 2. I hope to load everything.
  • Turn on the mixer in sequence. Engine Connect still has a bug in one of the Players, in my case the Player 2 turned on first, as you can see in the video below, but, as incredible as it may seem, when I access the LINK, it loads instantly! Very different from the videos shown above! Engine Connect interaction features are not affected even if the bug does not show the connections in one of the Players! The LINK working as it should, fast, in this sequential linking mode, made me very excited! I hope this can solve those who are having the same problem of slowness on the LINK!!

Thank you all!!!

I think we should draw attention of the developers to this post. This could help in solving this bug…


I have thesame problem here with my 2x SC5000m & X-1800 Mixer. Made some troubleshooting these days… What u need to know is, that i have connected an WIFI Router on the PC Port of the Mixer by cable. What i found out is: Without the Router connected to the PC port of the Mixer, the system works fine & Engine connect shows the right channel assignment. With the Router connected, it did not work right, the players are working together, but Engine Connect on the Mixer lacks. It seems like there is a problem with the Network, maybe the DHCP option on the router makes a problem. I dont know how special the network configuration of the mixer is, but it seems like that there is a dhcp server integrated, that assigned the ip to the player, when they are connected, but when the player get the ip from another dhcip server (like the wifi router) the system lacks like hell. So be carefull to connect other network equipment to yout Engine Setup, it might cause problems.

Best regards