X1800 Problems with firmware 1.6 update

Hi, hope any of you can help me! Last night I had the brilliant idea to update my x1800 from firmware 1.3 (it was working smooth) to the 1.6 update (latest) I did everything as requested. I used my MacBook Pro (Catalina) and the mixer reboot after the process, but I had an issue with the screen that looks crazy (like it has a virus). The mixer works well with my turntable and the SC5000, not issues with sound or anything else as far I can check. It just the screen.

If its possible I’d like to roll back to firmware 1.5 or 1.3, but when I try to do it, it says the mixer is up to date (and it is, but not as I wish)

Hello Upgrade again or reboot, it seems your update has not ended

Hi, as I said, I tried to update again but it says that the mixer is up to date so it won’t let me do it again, and I rebooted several times but same result. Do you know how can I force the same update or a roll back?

Thaaaanks

1 Like

Have you already tried the process to put the mixer in update mode?

Power off the mixer. Connect USB cable and power on the mixer. Hold down BACK, FX CUE and TAP until “Update firmware?” appears on the mixer (could be tricky to see on a corrupt screen). Turn FX select and click to select OK.