USB hard drive not recognised

Hi there,

This is my first post, so hello everyone - glad to have found this, and hope to play a positive part of this forum.

I have a question - I use a Transcend USB hard drive to store my music on - I am pretty sure either one of my SC5000’s would recognise the drive after being powered off and back on again, however that is now no longer the case - I now have to unplug the drive and plug it back in again for the SC5000’s to recognise it.

Anyone else have this issue, and is there a fix for this? All 3 of my decks are running firmware version 1.3.1.

1 Like

Hi @subwax and welcome to the Forum!

Is the drive formatted at Fat or Fat32? these are the only 2 formats the Prime series will recognise.

Also If you put the drive into a laptop does Engine Prime see it?

Regards J

I believe its Fat32. When I reconnect, the SC5000 can see all the tracks, so I think the formatting must be OK.

I have not tried to see if Engine can see the drive - I’ll check and get back to you shortly.

Thanks, also would be good to know how many tracks you have on there as well.

If possible, it might be worth reformatting the drive and re-exporting the music back on there

Let me know how you get on!

1 Like

Hi Jay,

I connected the drive to my laptop (Mac), and Engine Prime could see the drive - no issues.

Is a reformat still needed if the drive is seen by Engine Prime?

I have around 120 .wav tracks on there currently.



On mac, make sure you select “Master boot record” as scheme when formatting a drive in Disk utility as Fat32

Thanks, but is a reformat needed here? Engine Prime can read the drive just fine.

My issue is that when I power up the SC5000’s with the USB hard drive connected, if does not recognise the drive. I have to disconnect the drive and reconnect it, after which is it recognised just fine… I know it worked before just fine - I believe the upgrade from 1.0.3 to 1.2.0 broke it. I don’t think a reformat will have any effect, but I will do one tomorrow, and will report back once completed.


I have performed the following:

  • Reformatted drive
  • inserted to USB3 on SC5000
  • powered SC5000 on

No joy - it does not recognise the drive at all - it does power the drive up, but thats about it. I have to disconnect and re-connect the drive, while the SC5000 is powered on, before it sees anything on the drive, Once I do that, I have access to all my tracks.