Unable to load tracks onto engine prime

is anyone having similar problem as I’ve tried several times… no luck!

Could you tell us a step by step list of what you’re doing, as loading tracks into engine prime is working for everyone else.


  1. I open up engine prime, it shows the drive that I want to import my music from in the drive column
  2. I create a new crate called “my music crate”
  3. I click on the drive where all my music is and …

ok, once I’ve dragged and dropped a single track from my SD CARD it also highlights that particular track in RED

What file type is that track?

MP3 & mp4 - I’ve never had this issue before, until now.

when i double click to play track, it comes up with an error message " FAILED TO LOAD TRACK -File unavailable"

Does Your card have a small sliding switch on the edge, that locks the writing?

Yes… I’ve tried it on and off…

Should be on OFF (unlocked). Engine prime will create a new database or update the existing one, when You send Your tracks there.

ok thanks…