Source Song Library External SSD- Playlist/Collection Listing Bug(s)

Hi All,

I came out of an 8 year retirement of playing music for the Prime 4. So far so good.

Here is my situation for Denon DJ software peeps on what I have found RE their Engine SW:

When I started Engine Prime on the MacOS I pointed to an external SSD as my source library.


  • I find managing in Engine on my big screen and keyboard easier than on the Prime 4.
  • can create a Playlist on the desktop using the External HD as source, unplug the External HD and plug into Prime 4- no copying Playlists to the USB sticks.
  • mainly, I do not have to plug my laptop into the Prime 4 when creating a bunch of test playlists for mix testing.
  • it is just easier to do it that way… we are lazy Denon… who wants to update their on board hard drive via a laptop all the time? Not me… This seemed the most efficient way for me to deal with music and not with computers.

Engine Environment:

The left column below the Search Field I have on Folder to navigate to my Music Folder. I replicated the hierarchy in the Folder view in the column under my External HD name in Device column “Crate” view.

As I built out my Crate hierarchy I saw that hierarchy was mirrored in the column under the Search field.

Once the Crate hierarchy was completed, I dragged my music (from Left Column Folder view) into the Crates under the Device for my external HD. So far so good.

Then, I created Playlists under my Device.

I selected Crates under the Search Field.

I dragged music from the Crates under the Search Field into Playlists under the External HD.

Everything is stellar until you want to transfer your Playlists to a USB stick.

Why? Because my Playlists were created under Devices, and not on the Mothership of the Engine Software laptop. There is no way to drag and drop Playlists from Device to Device. You have to go through the Mothership column found under the Search field.

So, then, I create and name the same Playlists there, thus probably starting to confuse things for Engine… dunno… but then…

(And this is a key point for your developers that this posting gets to - under my use case circumstances, I cannot have the same song in more than one Playlist.- it took two days to figure this out, but wait, there is how I figured this out…)

So, I have song XYZ in Playlist 1 along with other songs. In Playlist 2 different songs, but XYZ. When XYZ is in a Playlist, when I go to add it into the next playlist, by selecting all of the songs in that playlist it would only load the first song- the playlist cut and copy from Device Playlist songs to Mothership Playlist replica failed. And then, I started noticing something - I started getting songs in the list field without titles and in the colour red…

As I tried to figure this out… everytime I tried, more songs showed up red in the list.

Ok, something was wrong. Why is this doing it… I try to find the XYZ song in the list, but it was not there, so I thought- definitely no title.

So I took my Mac OS Finder window and looked into the External Drive and saw the Engine Library. I looked on the laptop and found its’ Engine Library.

At that moment, my Playlists were on the Device, not the Mothership. My crates and songs were on the Device, not the Mothership… I was having issues with Playlists on the Mothership… meaning I thought I was getting a database conflict inside Engine causing the issues. In side the Engine Library I see the files. I see the matching ones, and in Finder, I copy over from Device to Mothership the database files.

Ok, well, that seemed to work, now, on the Mothership I have the Crates “local”. I see my “Playlists”.

And I drag my Playlists from the Mothership to the USB stick. The entire Collection had duplicate songs in red, since of course the directory listing for that had now changed.

I unplugged my External Device, and then selected all red songs on the Mothership and deleted from Collection.

I plugged in my External Device where the songs were, and everything populated.

Ok, but the big bug discovered is when I try to copy any song twice into a Playlist… it immediately looses its’ Title information, goes red and goes to the top of the Collection list based if you have it sorted Alpha or not.

Bottom Line I guess Playlists are to be created on the Mothership Local Laptop and only ever copied to the Device or USB Stick.

Never Create on the Device or USB stick since when you unplug it, it stops showing in the Laptop Engine window.

We need to be able to have the same song in different playlists. Maybe this is only because my music is on an External HD. Maybe if the songs were local on the laptop this would not be the case. But my Use Case is as I described.

1 Like

Am also going threw some of the issues you having as well. They are aware that engine has lots of bugs that have to be iron out. The more we share out issues that’s going on the better. I bought the prime 4 and it’s a great piece of gear. Engine is really putting a dent on it. It’s frustrating but the good thing is that they are aware of it and it’s going to be fix. When not sure but I hope soon. Thanks for sharing your info helps a lot brother


One thing to do with your Title-less songs that may show up in your Collection Listing:

Double tap the blank space in the Title column, and Re-Import Track Information.

1 Like

this is really helpful. thank you for typing all this out.

I’m embarking on a journey right now to properly sort over 5000 songs on a new external SSD.

i’ve really been struggling with Engine Prime’s …um… peculiarities lately.