[SOLVED] Prime 4 froze after update

I have just updated the software on my Prime 4 and now the screen is just stuck saying Engine OS and didn’t reboot after the update, I tried holding the power button on so it turned off but on turning the Prime 4 back on it’s still stuck on that screen. I have an internal SSD in the unit, not sure if that would or should effect anything. Please help.

What version did you update from & to, and what method did you use to do so?

Try removing it and booting the console without the internal HD. I noticed that many guys who have problems with the P4 also have internal HD.

1 Like

Hi, downgrade to 1.5.1 and wait before upgrading. The p4 has some lacks but works perfectly with this firmware. Preview will wait for final 1.6 version

Can’t do anything, won’t allow me to get back into the main menu just stuck on a black screen with Engine OS writing version 1.5.2

Hold EJECT and power on. Does that work to get it in update mode?

1 Like

Not sure what the old version was sorry, new version is 1.5.2, connected the Macbook Pro with USB cable, opened the software on laptop and then went to up date in Utility. It did all the updates but didn’t reboot after and just have black screen with Engine Prime 1.5.2 on it, no lights on the decks and can’t get back into any menu. Tried turning power off and on and still the same, tried running update again but won’t without getting back into menu on the decks.

Try to upgrade firmware using a USB stick and the appropriate firmware. Sometimes when upgrading using PC or MAC, problems happen. Then force the firmware update mode as Reese told you above.

Hi Reece got home and tried that and it does nothing, acts like its going to shut down and hear a fan or something start up. But when you release the buttons it returns to the black screen saying Engine Prime OS and nothing works, need to know some kind of a hard reset. I have tried turning the power off and when starting up again try to run an earlier version of the software but it doesn’t detect the unit and I can’t go into anything on the Prime 4 as you would to accept the update.

I hope they are fine, my p4 is frozen, a message appears that it is not connecting some peripherals.

help please

Thats what just happened to me also…So what I did was…I turned it back on and only held down the eject button for a min or so and the lights began flash and after a min I let go of the eject button and it went to the Engine OS screen and it changed to some reboot screen and I let it do it’s thing…And when it was done it rebooted and it is now running…I was about to have a heart attack lol…I upgraded from 1.4.1 to 1.5.2…I also updated using the USB cable to my 2008 Mac Pro…And I have a Samsung SSD EVO 860 1TB installed.

1 Like

Sounds like we have the same set up and exact issue, I was trying to update from 1.4.1 to 1.5.2 from the laptop then it all went wrong. How did you turn the Prime 4 off to enable you to turn it on again and hold the eject key ? Is it worth upgrading to 1.5.2 ?

All I did was just hold down the power button until it turned off…then I turned it back on and held down the eject button and once I saw the lights running and flashing for a bit…then I let the eject button go and it went to the Engine OS then it changed to the boot up screen and it shows the updating progress…I wish this would let me up load a pic or vid of what im talking about…and so far I have noticed when you load a song its really fast…and there is something about the sound…it sounds more clear for some reason…or im just going crazy lol…the reason why I wanted to upgrade bcuz I plan on going back to being a mobile dj…and I would like to be able to record what the ppl at the main wedding table have to say on the mic when they pass it around…and with this update you can do that…I think it would be something nice that I can throw into the wedding package…But this weekend I will put this update to the test!!!..I was able to update the Prime Go with no issues.

1 Like

Hi thanks for the reply, I’ll give it a go again and see what happens. I am a mobile wedding DJ and want to use this unit but am finding it hard to have the confidence it it like I do with my Pioneer DDJ SX3, I had intended on selling that and having a Prime Go for my back up system but now a little worried. Definitely record the speeches its a nice touch, whats your DJ name on FB ? I’m DJ Amped, I’m an amped up amplified amputee ! lol

Lol nice!..and you’re welcome…and on FB it’s KING BLVD and on my other social medias its KINGBLVD5…but let me know if it work for you…I used to use Numark for years!!!..started with wax then cd’s then controller and got tired of always having to hook up my controller to a computer and thats when I seen the Prime 4 coming out and I pre-ordered it right away…and im so glad I did bcuz I love it!!!..its weird to me that ppl buy the Prime 4 and still use Serato…why not just buy a controller…but I guess to each thier own…I just use my computer now to run SoundSwitch and Resolume Arena 7.

1 Like

Hi, I tried the update again using my Macbook Pro, followed your instructions but after the update it just stays on the screen saying Prime OS and doesn’t reboot back to the internal SSD and music folders ready to play. So had to go back to the earlier version and that worked fine, did the update once done it rebooted on its own and ready to play. Did it take long for yours to reboot ?

Sorry it didnt work…and yeah it took a little while…once I did the update and it got stuck on the Engine OS screen I let it sit there for 10mins and then I powered it off and did what I said I did

Hi tried the USB Fat32 update and that worked, thanks for all your help guys!

Maybe if you tried 7 days ago (when I wrote it to you, see above) by now you had solved it for a week. There are often problems with PC / Mac upgrades.

1 Like

HI, I probably should have but when so many others didn’t have any issue I just thought surely it can’t be that, any way appreciate you trying to help.