SC5000M Linked - Sync Issue - Fast Spinning Platter

Sync just won’t work when the players are linked to the X1800 mixer, tempos always drift. This is the 2nd set of machines I’ve had so it’s not a hardware issue.

On this new set I’ve tried to connect the link cable between the 2 payers instead of through the mixer. When sync is activated the second player starts to play OK then after a few seconds the patter spins at twice the speed and so does the track !!!

Any ideas ?

Can You make a video of this to help better see what is going on? Or please make a list of things that You do, maybe I can reproduce the issue at my setup?

Thanks for the reply. I’ll get a video of it tomorrow and post then.


Are you using the latest firmware?

Hi - updated to the latest firmware and that issue has dissapeard but now have a different issue. Sync is just totally off. Starts off OK then after a couple of seconds goes out and the sync button starts to flash and will not go back in sync.

Also, there is no way I can match tempos when the platter is spinning !!! When I turn off the motor, tempos are in sync !! ■■■ !!! The whole point of having these machines is for the spinning platter. Video of them in sync with the motor off - Video with the motor of, totally out of sync -

Is this a hardware fault maybe ? Anyone else seen it or had the same issue ?

I don’t use sync. You should log a bug in that sub-forum.

Thanks but this isn’t a sync issue. This seems to be an issue with the motor. I don’t have sync enabled in the videos, the issue happens when the motor is on. 2 tracks of 127bpm are totally out when the motor is on and perfectly in sync when the motor is off.

1 Like

Try using the same track in both decks and see if they stay locked in

Hi - did that, same issue. Impossible to beat match (either manually or using sync) when the motor is spinning !!!

That means one (or both) platter isn’t true to pitch. I wonder if there is a calibration mode like the Rane Twelves.

Try to check which platter isn’t true by using the auto bpm detect feature of the mixer (assuming you have the X1800, connect the players to each other directly)

Let the mixer calculate the BpM using Auto.

Or toggle off the Engine connect of the mixer.

Did this ever get resolved ?