SC5000 V1.2.1 - Update

That space before the sound kicks in is deadly.

Nothing fancy to the updating process, I hope the folks having issues get sorted soon.

I used a blank USB thumb drive for my update. Not so sure if having stuff on the key previously would mess things up. Took the safe option. FAT32 MBR.

Ditto. I always use an empty thumb drive for Firmware updates on hardware. I have a 2GB thumb drive I keep in my bag just for this now.

any solution to the problem of the video?


I’m having a similar issue.

One SC5000 updated fine via USB to PC.

The other is freaking out. It freezes after turning on at random times (ie. sometimes at the loading splash showing v 1.2.1, sometimes I get to the source page, sometimes I can load a track - but can never get it far enough to play). It has to be hard-booted each time by holding the power in for 5 seconds.

Have tried re-updating it via USB several times - the process works fine but the result is the same. Cannot update via USB now because I think it does not consider a v1.2.1 image on the USB to be an update to the already running v1.2.1 on the player.

Please advise.

I recently updated both my SC5000’s, both with the same method via PC. The first unit I updated without any issues, firmware installed and unit working fine. The second unit, the firmware installed but the unit would freeze while playing. I tried reinstalling the firmware v1.2.1 multiples on the second unit and it continues to freeze within a couple of minutes, some times a few seconds upon rebooting. I checked device info by hitting the Utility botton on both unit models, the model that does not work is SC “Stannowski Chiller” 5000. The unit model that works is SC5000. Can someone assist???

Updatet with USB and that was successful, but after that nothing works…

I don’t have the same issue, when starting the unit the screen freeze at the start and nothing works

Yes - I’m having a similar (or most likely the exact same) issue.

no problems with the usb hav checkt it on the pc, i hav a succesfully update 1 player. its just dont work on the other player.

I did not update via usb stick, but with mac and usb3 cable. No problem. The 2 players work well, no hitch even if I tried them for 10 minutes after the update. I will try again this evening for more time. We hope well…

But this new problem that you accuse is given by the fact that you have all updated with usb stick?

I updated both players with USB sticks. No issues.

I noticed the players seem to boot up and shut down faster with this new update. Or am I imagining things?

Not for me - I used direct to PC with USB cable.

… i skipped 1.2.0, and now 1.2.1 too i think :thinking: what goin on here …

Successful firmware update here. Only issue I noticed is that the playhead marker on the center jog display lags when using the censor button. Aside from that, everything works as normal.

yes it’s exactly that, plus we can not put the player off

I did not pay any attention to this … tonight I try again

What do you mean? explains

Guys - what’s next?

My unit is freezing within seconds of every reboot after having applied the v1.2.1 update. The update has bricked my player.

What is the roll-back path to v1.2.0 - I see no way to download it on the website.

How can I do a facory reset, access logs, or get further info?

Please revert.


I comment. I installed the 1.2.0 update for the pc. It works perfect. I installed again via usb the 1.2.1 fails. I installed 1.2.1 for the pc and it also fails. I got the 1.2.0 on one of my players until further notice. I have the update 1.2.0 I upload it tonight to be able to repair your players

Dear Members

We have found an issue during updating with the v1.2.1 firmware that has affected a small subset of SC5000 users’ hardware. Users experiencing this can temporarily roll back to v1.2.0 and continue to use the players with confidence. Our team are working on a priority fix for this issue and we’ll notify when this is complete for updating to v1.2.1.

We have put the 1.2.0 update files back on the website. Our sincere apologies for the inconvenience.