[Resolved] SC5000 v1.3.1 Only Controls One Deck in Serato DJ


We discovered an issue with SC5000 1.3.1 build when used with Serato. It seems that after performing the update 1.3.1 update, the deck will only control deck 1 within Serato DJ. We have since pulled the 1.3.1 download links and are investigating this with the highest priority. If you are suffering this issue please comment and follow this thread for the latest update and fix.

We deeply apologize for this inconvenience and will have more information very soon.


That’s the importance of an open beta. Just saying. We are all here to help add value to the engine Prime ecosystem.


Hi @mufasa, I fully agree the more eyes and hands we have on testing the more solid our releases will be. We will be reviewing our Beta testing process post 1.3.1.


Does this affect the x1800 or is it safe to update it to v1.2(x1800)?

1 Like

No, only the SC5000. All other updates within the Spring Release are ok safe to update.

1 Like

Why not simply put the links up with a DON’T UPDATE IF YOU ARE A SERATO USER banner above it…


Is it only serato issue? I dont use serato. I used your workaround and got the needed files… Much good tip!! Havent installed them yet. Or do you think its gonna be patched soon, with tempo/bpm adjust?!

Patched only. New stuff will be in new release, I guess.

Thanks mate. So no serato use is no problemo? And i do much like when u gues and assume thinks!

Don’t experience problems. Haven’t also actually :wink:


Anyone have a download link for the update, pre-removal. I’m not a Serato user and would like to get my hands on the update.


I would to! I hope they give us a link

thank you i really appreciate it friend <3

Wait another year for the update? Seriously… Nobody at Denon DJ staff tried the new update in Serato?!?

1 Like

Seems like the links are not working anymore? It throws 404 for me.

That’s what I’m thinking, I have NEVER used Serato…EVER. So this doesn’t affect me. To each his own, but it still baffles me why you would want to use this with Serato or a laptop in front of you anyway. And you mean to tell me they didn’t test this build out with Serato before releasing it??

Thanks, I’m downloading it right now

I don’t know really.

I’m having trouble loading 1.3.1 on my SC5000. I loaded 1.2.2 with no issues. I’ve tried both methods without positive results. To make efforts a bit more confounding my X1800 has started to make that strange clicking sound that I had my original unit replaced for. Any insights on to what might be happening in regards to the firmware update? As for the mixer problem who can I refer that to…