Problem with my P4 P2 and Go not being able to see my Ext SSD when plugged in!

Hi All,

Wonder if anyone can help. When I plug my External SSD into my P4 P2 or Go it is not found i click SOource and it is not there ?? I have to power up my laptop open engine Dj plug in my Hd and let it take about 5 mins to go through its sequence, then when no jobs working I can eject the drive from my laptop and re plug into my controller, then it finds the SSD.

This may be ok for around 2 plays and eject sequences, i may leave it for one day and plug into my player again and same thing happens not discoverable? can anyone help ?? It never did this before and It isnt a bad drive as its new and i also have a cloned back up SSD which also is not found on the player ???. I have tried pressing the eject button on the player but the same thing happens. So i turn off the machine let it turn off then eject my drive. this only seems to happen after update 2.3.2 ??? can anyone help please ???

Worst nightmare is going to a gig plugging in hard drive and not visible ahhhh. Id not take my laptop so i can plug in a harddrive into engine dj or whats the point of a stand alone machine ? please help thank you :slight_smile:

I also use an external SSD (USB3) on Prime 4. Sometimes it happens that after turning on the console, the SSD it is not detected. I also pressed the eject button, then disconnected the USB connector and plugged it into another USB port both the blue colored ones and the upper white colored ones, but it is not detected.

The solution was to restart the console. It was later visible again. I always do this when I have the SSD not visible problem.

Thank you.

I will attempt this although i am sure i have before. Do you leave the SSD still plugged in just turn off and back on again ??

By any chance are you both using Macs with Ventura?

See here:

I am also having a similar problem. It has only happened with the latest update.

Could this be a possible bug report for 2.3.2? I would honestly be relieved if this is a bug and not my Prime 4 USB ports dying or something.

Here is all the info I can think of related to the issue (as it has affected me, on my device, anyway).

  • It’s not a formatting issue, this is the drive I have always used, and it does work most of the time (I don’t think it would ever magically be able to read the drive if it was formatting wrong). I am on Windows (so not the Mac OS Ventura thing), and this isn’t a newly formatted drive, it’s one I’ve been using successfully for a while (like… years).
  • When it happens rebooting the Prime 4 fixes it, so far
  • I don’t think it’s an issue with the drive… I tried a different drive once when it happened, and it wouldn’t read that one either. Both drives work perfectly fine on my computer, and on the Prime 4 after rebooting it
  • Last time it happened I tried plugging different drives into all the USB ports and nothing worked. (top and back USB ports, one thing I haven’t tried is an SD card)
  • I’ve never had a drive all of the sudden disappear while playing. It seems to be all or nothing for the entire “boot cycle”.

I think you are quite correct and a possible bug. Currently the only way i can get round it is to plug my ext hd into my laptop run it through engine dj until its finished “No Jobs” then eject and my machine finds the hd then. The reason also i say its a bug too is because my prime go does the same and is the same way to resolve too. Not good however if you go to a gig plug in thinking all is ok and then it wont find your drive ?? what then ??? NO MUSIC !!!

I just realized… I’m not actually sure how to submit a bug?

I do not know either, this has to be a big though