Prime go Problems after 1.51 update

Deck 2 is sometimes unresponsive have to restart prime go to get control again. Is there something I should check I never had this problem until I updated.

1 Like

You can check it, if you reflash to 1.4.1 … if the problem is then gone, then there is a issue in the latest firmware.

Same here, FW 1.5.1 and Denon go deck 2 just froze on me. I was playing track from Tidal. I could load new tracks to deck two, make loops, set cue points, change tempo and even press play so that the play button stops blinking but the waveform just won’t roll. I can even scratch and have sound from the track, but it just won’t play. I made a short video clip if Denon is interested. I just lost my trust for this little thing. Nice for home use but not for pro.

Hi, same problem, only on deck 1 to me. Randomly, the track plays but after some jogwheel uses it refuses to start again.

All i can do is to shut down the Prime Go and restart it. It seems i have not the problem on the Prime 4.

All controls work except the start button which lights on/ blink but does not start the song.

I had no problem on 1.4.1

Must reinstall firmware 1.4

where is it?

On under downloads - there you choose older files … and you can download all older firmware as well.



Firmware update (PC)




Firmware update (Mac)




Firmware update (USB Updater)




User Guide (English)



Try this,

While the unit is booting up, place your hand on the platter until the system is fully ready to go. See if this corrects it because I had this happen to me also but I thought it was a result of something else I did to my unit.

I think by doing this, it’s a form of platter calibration for the software. It doesn’t have a calibration in the utility menu like the larger Prime units. It only needs to be done on the platter with the issue. For me, it was the left deck. I haven’t had any issues since I did this.

For me this issue has happened only once. So I think it is totally random. Since it happened I’ve logged many hours without issues.

It happens to me everytime I use the P Go on 1.5.1

Randomly but it sometimes happen when I turn the jogwheel fast.

It can be about 5 minuter after booting or an hour after…

Haha, I tried to make some fast jogwheel moves with my GO and I managed to get my Vinyl Mode button to get stuck on Nudge Mode. I made another video to Youtube called “Denon Prime Go issue part 2”. It’s hard to say if its the FW 1.5.1 causing this problem but the troubles started after the update.

I think there are some timing bugs in the new firmware. hope it will be sorted out soon. But so far, if you don´t stress the system too hard, I haven´t much problems with this firmware.

Yeah, I think you just have to be careful with the jogwheels

Yep yep… After 2x one hour gigs, I think I may have found something : maybe it is a Ground issue. If you power on the Prime Go being nude feet or with sweaty hands it can causes One deck freeze in minutes…

I’ve had this issues with deck 2 not being able to play at all twice. Resetting it fixes it. Has anyone confirmed that reinstalling previous firmware will fix this issue? Also I can’t find 1.4.1 for the Prime Go firmware. Any links?

1.4.1 firmware is on the denon download site. A little written hint link … under the description to the newest firmware.

but for all they dont find it:

I think they want the PrimeGO 1.4.1. :relieved:


then we have a problem - whitney LOL

As I see … there is only 1.5.1 listed …

I had this problem once during a gig last weekend. I got a request for a song I didn’t have on my flash drive so I tried loading it from Tidal. I got the same sort of performance issues that OP mentioned. I restarted the Prime Go and stayed away from Tidal for the rest of the gig and had no trouble.

I tried to recreate the problem when I got home and I couldn’t. I thought maybe Deck 2 just hates Abba :grin:. It was my second gig after updating to 1.5.1 and I had played a gig the day before with a few Tidal requests (including a country song) and neither deck was quite so choosy. I had to tether to my phone because I don’t have local network access at this gig.

I’m going to be hesitant to play from Tidal during my gigs with the Prime Go until the next firmware update. With an all in one system it can be really awkward to have to restart to get music going again.