prime 4 not recognising drives and saying peripherals not coming on line

Hi only recently purchased the prime 4 - so not used it much never out yet! Updated the firmware to 3 and since whenever i turn on the unit - it doesn’t show the onboard hard drive that i put in - neither does it recognise any usb. The only source it shows are the online ones or sample. - If left it eventually shows a display saying the following peripherals did not come online during boot - controller, mixer, left and right display - then asks to update - which if i update all then works as it should but if i power off and return the next day - the problem re appears - anyone come across this and have a solution please

I think you need to re-do the upgrade but using the usb cable and computer if all you did is select the update over the web.

Thank you - i tried that too. Also have tried reverting back to previous firmware but problem still exists

Then contact the store where you bought it from for return/repair, there is obviously something wrong with it.

Definitely contact the store.

I’ve read people get theirs replaced as it’s a defect. I had it but it went away. It seems that yours is persistent so get it changed.