No tracks found after 3.0

Hi so after updating prime 2 to 3.0 it worked fine and power cycle the device a few times even dj for 6 hours no problem, AFTER the party/power on prime 2 at home, the collections says UPDATING and then says NO TRACKS FOUND. What happenedt? THIS IS WEIRD I go to history and see all 6 hours of music and load up those songs with no problem, again I go to history load up songs and are able to play. What’s happening? So I downgraded to 2.4 and guess what? same problem, CRAZY!!! HELP please

TImeline: Running 2.4 both on Mac & prime 2.4 Upgraded over the internet prime 2 to 3.0 -worked fine Days later upgraded Mac to engine 3.0 - and I can see my collection Same day turn on prime 2 and problem started Day later connected prime 2 to Mac using usb cable and engine sees prime 2 and my collection with folders and history but no tracks are shown only the tracks on history So I downgraded prime 2 to 2.4, nothing changed, can’ see tracks I see all my playlist Then upgraded to 3.0 because is the latest, still can’ see tracks

There’s a couple of things which spring to mind.

So, some questions.

What version of firmware and Engine DJ on pc did you upgrade to 3.0 from? 1.x ? Or 2.x Your post says you rolled back to 2.4 but that might not have been what you upgraded from?

Reason for asking the above…. The entire database structure in ver 1.x is different from that used in ver 2.x. Then the database in 3.x is different from 2.x again,

Each time there’s a database change, the engine DJ software on OC/Mac has to be updated to the version which matches the database version which the players OS/firmware have in them. The engine DJ software will then look at the database version on each of you hard drive (or driveS) and if it sees an older database version on the drives, it will start a migration process on each drive (allow about an hour per thousand tracks - depending on pc spec/speed of course - it takes ages but only has to be done once. Did you let the system do that when you upgraded to 3.x ?

However, I don’t know if old versions of engine DJ know how to migrate backwards eg engibe DJ ver 2 taking a ver3 database back to ver 2 so that old 2.x firmware can read and migrate the database back to 2.x. Logic says that engine DJ 2.x can’t possibly know how to read 3.x or migrate it back to 2.x in any sort of rollback. But… the migration might have saved a folder called “old database” on each drive, which might just need renaming.

maybe it boots on content sample and not on Source SSD???

Hi, thank you for answering the theory about the naming the folder sounds good. I updated my questions goes like these running 2.4 both on Mac/prime then updated prime to 3.0, days later updated Mac to engine 3.0 and yes I think there was a process on my collection (25K tracks) and now Mac engine shows collection. I connected prime to Mac and engine sees my collection with folders but no tracks, only history tracks.