My Prime 4 won’t update

Trying to do the latest update but it’s just stuck in updating mode… I analysed all my tracks aswell and ever since it’s been really slow to load them or when it does load them it plays for a couple seconds then keeps stopping??

Hi @Kfidgett,

Sorry to hear you’re having trouble updating.

Have you tried following this help guide?

Yes I have, I tried updating it via usb, it appeared to be updating correctly but when it was done, I think it was still on the last update as it still said 1.3.2 or similar when the update is clearly 1.4??

Yes, you should see 1.4 on the slash screen during start up. You can also verify version number in the utility menu.

I couldn’t get it to update through the usb so I’ve done it with the pc instead, all updated now but it’s still very slow to load tracks, when it does it cuts out and plays sections of the previous track loaded?!? Only started I analysed all my tracks on rekordbox and switched to a Kingston usb instead of Sandisk