Left jog wheel not showing art

Got this unit 3 days ago was working fine now the left jog wheel is not showing anything in the middle . Still plays music but no art showing . Got the error message did the update still nothing not sure what to do now

What error message?

If Your MP3’s don’t have any cover art attached, then it will not show up.

See below of image , I followed the instructions and no changes

Error code is prime4 left display 00.34

Did You tried to update the unit again?

Yes I have updated the unit , read some other forums and still getting the same issue , the left side won’t power up as the right side does

Looks like that awful peripherals not coming online issue affecting quite a few of these units. Seems the only solution is to send it back for a replacement.

Denon need to look in to this urgently as it’s now happening more and more.

That’s exactly what I was trying to avoid . I like the unit alot and for it to be this new to me and I’m Having issues now after 3 days it’s not a good sign

The thing that worries me most is if any of these peripheral failures happen when you turn up at a gig, hence a statement from Denon wouldn’t go amiss.

That’s what is worrying me right now . I would assume going through the retailer I purchased from but if they send me a new one denon is really not aware and it may occur again . Also much appreciated for responding and trying to help me resolve the issue

May be worth raising a support ticket with Denon anyway so they know the serial number of the unit.

I just spoke with the retailer And they had 3 returned and in “repair” with the same issue. I had sent a ticket with denon last night just to see if there was a fix to it but looks like there isn’t which is sad

It seems doing firmware updates into denons isn’t very healthy for the gear.

Maybe this explains why denon don’t do any little weekly firmware updates, only a annual (feels bi-annually) mega update with 20 or 30 things on. It minimises returns…

@Domg so in summary: you received your PRIME 4 a few days ago, you used it with the firmware you found installed and everything worked well. Then yesterday you upgraded the firmware to the latest version and now are you in this situation? EDIT: If the problem occurred after firmware update, you can also specify: the previous firmware version, the method you used to update the firmware (USB or PC or MAC). Thanks.

I updated the prime 4 the day I received it and it was working fine yesterday I was using it after a song the left side went out tried rebooting several times and no change has happened. I was having difficulty reinstalling the old firmware I tried to go to denon archives and download and my Mac would not accept the old version to load

The latest firmware is 1.4.1 and was released in late December 2019. Now I wonder: why does a new console purchased in May 2020 still have an old firmware? @Domg: Did you use a USB stick or a PC / MAC to update the firmware?

The console came with a 1.3 version and I updated to the 1.4. I used usb from my Mac for it as it said on the instructions the console came with . I was reading forums and it said to try and revert to the old firmware and then try and update to the new one

The MCX8000 I bought in November had old firmware on it that had been replaced a year before at least. Must just be a Denon thing.

So the retailer is going to send me a new one fingers crossed and prayers for the next one

Yesterday I received mine PRIME 4: firmware 1.3.1. Strangely, when it is turned on, it offers me to update the latest version on my own. For the moment I have not updated yet, but I am amazed at how the PRIME 4 knows about the new firmware if it is not connected to the internet. :thinking: :thinking: :thinking: