Jog wheels started go crazy

Dear members, Denon Team, Since March 2020 i purchased my Denon Prime 4 the device is placed in my playroom in the same place all this period of time. No events or parties just in house use.

2 weeks ago as i was playing music the left deck freezed playback like i was touching the platter but i wasn’t.

As i dont want to write too much 2 weeks now some days happens to the left and right is ok some other days right is freezing and left is ok. House ground is not the case as it is in the same place from the 1st day.

What i discovered now is that when i power up, the right deck is freezed blue color (if i touch it nothing happens) l and the left is ok. But after 30 minutes if i restart the unit ( i suppose it is warmer) then both jog wheels are ok. Question, as i understand i have to go and check it to an authorized service but as they will disassembly the unit i am afraid of scratches that maybe happen.

Does someone else have to suggest something? Firmaware 1.6.2 but this is not the problem. Most strange in this is that sometimes happens to the left and sometimes to the right. Please give me your lights

A video link of what is doing

Thank you.

Already mentioned that if you had read the entire post.

I would double-check if lack of grouding is the problem. Even if it is on the same place from the 1st day, a bad power cable, socket, other equipment plugged to the same socket line, etc. may be causing the problem. I would start by trying another power cable / plug it on other socket at home.

Thank you both of you. I have try all these, disconnect xlr rca took power from apartment and not playroom the same behavior. Now 3 days I power up with right deck vinyl mode frozen and if reboot after 20 minutes both deck work fine. As it happens to both decks, not same time, maybe it is something wrong with internal ground cables but I feel very sad with the idea that someone will open the controller.

You should check if anything nearby is creating radio emissions. This is one confirmed cause of bad jog behaviour.

1 Like

Wyley1,

Thank you. I have read this about leds but its not my case. Now i just did a trick and before i answer what is /was wrong i ll wait to test it until Sunday. If everything is ok with the unit i will let you know of course as many have this issue and maybe dont need to go to an authorized technician for this.

Lets see tomorrow morning as now what i did it worked.

Hopefully it works out.

Just to mention that it was the leds creating the radio emissions.

Led’s can’t emit any high frequency radio waves, but a led power supply sure can. If there was any power supply added recently to this room, near the p4 it can be maybe affecting the jogs touch…

His was radio controlled. If radio emissions are the case then it will usually be hidden in plain sight mostly something you don’t expect.

It’s worth a shot just to give en extra look for it.

Dear members, what I discovered and did this afternoon has to do with jog wheel position in the controller. I read somewhere today bu ti don’t remember where that platters maybe after usage may sit below some mm instead of factory position. So this afternoon I took 2 very small flat screw drivers and placed them right and left of the jog wheel and very slowly I pulled the jog wheel up. Don’t think any big movement just a little. I did it on both jog wheels and power up the controller and both jog wheels worked at one absolutely fine. Maybe this is the case but I will confirm after several start up of the controller but I suppose this is the case, after usage or if someone play with jog wheels and pressed them hard by mistake, for example my son maybe, this may cause this issue. I will let you know.

2 Likes

@dj_chris - Glad to hear some of our community members are troubleshooting with you. If you need further assistance, feel free to DM me and I can connect you with a technical support agent.

1 Like

Dear Anthony, nice to meet you. In the past Jwill and many members helped me a lot and I also tried to help other friends with prime 4. So no complains, forum is great.

But if you read my last reply of what I did it would be great to make a question to Denon technicians if platters after some time of usage can be out of center or height (platter sits on an axis) and cause this issue regarding touch sensitivity in vinyl mode. Thank you!!

1 Like

Ok, my trick i did last night is not working. As unit is cold i powered up this morning and right jog wheel is blue and in vinyl mode touch my hand and no change. After 20 minutes i rebooted the device it works. So maybe its a faulty sensor or entire jog wheel need replacement. Does anybody know if the sensor exist as a part or technicians willl ask to change the whole platter?

Thank you

You can try to clean the jog with antistatic cleaner for pc or a pad with a reduced alcohol/water mixture. Maybe some oil or other electrically conductive residues are on your jog. So it measure a little resistance from ground, and this causes the stuttering. Maybe a freshly cleaned jogweel should fix it. if not the sensor is broken.

Thank you Dark. I will try it. If the sensor is broken then replace part the sensor or entire platter? Also if you can help on this, the platter after 30 minutes of power up the unit and then if I restart it it’s OK. strange this.

Don´t know what they will change on repair. If it is the complete platter or only the sensor. There you have to contact your local dealer, and he will contact repair center for you.

When all our tips don´t bring the desired success, you can also contact @Anthony_DDJ .

wish you luck.

1 Like

Thank you!!!

So, all seems to be a hardware issue. Cold controller first start of the day, right jog vinyl mode is not working by touch. After 30 minutes the jog wake up and touch works OK until next shut down and stay for 2 o 3 hours off. So is it pcb or jog sensor? Who. knows? I have to go it for service at the end.

Hey @dj_chris We’ll be happy to take a look if you feel if it’s a hardware issue. Could you DM me your information (email, name, phone number) and quick summary of what you’re experiencing and I’ll be able to connect you with a team member.

Have you tried … recalibrate the jogs in cold mode ?