Having an issue with adjusting the beatgrid on the fly on my SC6000's

I’m really scratching my head at this one, although it has happened before, but I don’t remember exactly how it was solved. it appears that all my tracks beat grids are locked when I transfer to my library on my internal drive on my SC6000. none of my tracks are locked however in my library on my pc. I’ve lost the ability to adjust the grids on the fly on my players. although it seems when I load tracks to a usb most tracks stay unlocked. any suggestions would be appreciated, as I have had this happen before, fixed it somehow lol and now that I re-vamped my library from a clean formatted internal SSD in my player.

In engine desktop look at locked track. In the EDIT panel on left click the padlock to unlock status

Yep I checked them for the un-locked lock pad and everything is unlocked. When I export to my internal SSD on my SC6000, almost every track is locked and can’t be adjusted on the player. I’m going to reformat and export my library and try exporting one folder at a time and check them as I go. Fingers crossed

Mmmm can you put the 6000 onto engine dj and see from there ( i know you can on prime4). If they are locked on 6000 that explains why you cant edit grid. But you should be able to lock/unlock through engine

I’ve had the issue in the past and recently had a few tracks with that “locked” state again. Last time I could solve the issue simply by re-analyzing the tracks in Engine DJ and syncing the thumb drive again.

I think I may have figured it out to an extent. I think it’s because my engine library is from my rekordbox xml. I tend to keep them the same and use rekordbox as a back up. But in this case I wiped my engine library and uploaded from rekordbox in xml format. All tracks show unlocked on my desktop but once I transferred them it wouldn’t allow me to adjust on the fly.