Engine Prime not loading

After installing the new update for EP it now just loads a black blank screen and nothing else. I can’t uninstall because a version of EP is already running apparently. Any fixes for this?

More info needed

Windows or Mac

OS version

Windows 8

Ive managed to uninstall and try again, but it now says im missing api-ms-win-core-heap-I2-1-0II and when adding this it still wont start

Hopefully some of the expert Windows users will chime in. My Windows knowledge is Netscape era.

My knowledge of Windows is also fading away, but I seem to remember that right clicking would allow one to choose Properties, then in the Compatibility tab, which version of Windows to simulate for program you intend to run. May be worth trying.

When you uninstalled Engine Prime you should have performed a registry cleanup first and restart de computer.

Has this been fixed because I don’t see a resolution here and am having an identical issue. I installed and repaired all of the C++ Distributables thinking that might have been it, but it clearly wasn’t. Google is next to useless on this one. Can we get some assistance from Denon Support here maybe?

Hi and welcome to the forum Chylde!

Let’s gather some more info about your system.

C++, so I’m guessing Windows? What Windows version do you use?

Another thing to try: Engine Prime is directx based, so is your GPU driver up to date?

Which Engine Prime version did you install? Have you tried installing as an Administrator? Did you try the public beta also?

First, my relevant specs: Operating System Windows 8.1 64-bit CPU Intel Core i3 2370M @ 2.40GHz 61 °C Sandy Bridge 32nm Technology RAM 4.00GB Single-Channel DDR3 @ 665MHz (9-9-9-24) Motherboard ASUSTeK COMPUTER INC. X55CR (SOCKET 0) 62 °C Graphics Generic PnP Monitor (1366x768@60Hz) Intel HD Graphics 3000 (ASUStek Computer Inc) Storage 111GB Crucial_CT120M500SSD1 (SATA (SSD)) Optical Drives PIONEER DVD-RW DVRTD11RS Audio High Definition Audio Device…

So, I am running updates like crazy. This thing hasn’t even been powered on in 4 years. But I updated the Redistributables, Direct X, and .NET Framework files, and that alone should have worked for this particular kind of .dll error, from everything I can find in my troubleshooting anyway. I have run everything as an admin, and even added the “Take Ownership” option to my right-click context menus, and taken ownership of my entire Windows folder, and every other program or file on this machine… If we can’t figure something out through collaboration, as a last-ditch option, I willtry upgrading to Windows 10 and see if that might fix the issue. I would prefer not to do that though, as I am extremely rural and using a spotty mobile connection tethered to the laptop. Not only will it use immense chunks of data, but it will move at a snails pace as well.

Also, it should be noted that Windows 8 and Windows 8.1 machines can only run DirectX up to version 11.2. You have to update to Windows 10 and beyond to ever use anything past DX 11.2. Also, there is NO standalone updater for DX 11.2, so it requires updating through Windows Update itself.

Does the Engine Prime Software work with DX 11.2?

Aaaaaand, oddly enough, the friggin’ Beta fired up first shot.

1 Like

I ended up just buying a new laptop…

Hello, I have a macbook with OS X EL CAPITAN version 10.11.6 I downloaded the engine prime software from denondj. installation was successful, however when i hit the icon to open it up, my computer just makes a “ding” noise but won’t open. When I go to spotlight search and hit on engine prime but won’t open. Please help

Hello Chylde, Please note, that recommended operating system on the PC is Windows 10. Older windows versions are not tested. It may work or not. But if You install win 10 - all should work.

@monchisthedj Oldest recommended OSX is Sierra 10.12. Maybe updating to Sierra will solve Your problem? Please try and let us know.

1 Like

I downloaded an engin message from the website: “the specified program requires a newer version of Windows” I have Win10 DirectX12 updates done and I can’t do anything version 1.2.2 engin also doesn’t work :frowning:

Did You tried version 1.3.x??

All, from the oldest to the newest

Hi @cipun1, welcome to the forum!

It’s difficult to help, but could you give some extra info:

  • Which version of Windows10 exactly? 1903, 1909 etc.
  • Are your GPU card drivers up to date?
  • Have you tried by executing as administrator using right mouse button?

Which version of Windows10 exactly? 1903, 1909 etc. - mine is 1909

Are your GPU card drivers up to date? - good question, I’ll check but probably new catalyst

Have you tried by executing as administrator using right mouse button? - tried, it didn’t work

Weird stuff @cipun1.

If possible, try another Win10 machine.

One last thing you could try is the public beta 1.4.1.